在线检测未来函数

通达信涨跌音阶指标公式

来源:Internet,编辑:股旁网,2013-03-21

该指标只是短线可能上涨的一种信号,信号量一般,短线成功率较高。

WR1:=100*(HHV(HIGH,10)-CLOSE)/(HHV(HIGH,10)-LLV(LOW,10));
WR2:=100*(HHV(HIGH,6)-CLOSE)/(HHV(HIGH,6)-LLV(LOW,6));
涨8:=WR2<10,POINTDOT,COLORRED;
跌9:=WR2>80,POINTDOT,COLORWHITE;
DRAWTEXT(涨8>0 ,1 , '$'),COLORRED;
DRAWTEXT(跌9>0 ,0 , '#'),COLORWHITE;
SZ:=C>REF(C,1);
XD:=C<REF(C,1);
ZF:=(C/LLV(L,5)-1)*100>=5;
DF:=(HHV(H,5)/C-1)*100>=5;
DZSJ:=BARSLAST((C/REF(C,1)-1)*100>=2);
DDSJ:=BARSLAST((1-C/REF(C,1))*100>=2);
涨3:COUNT(SZ,3)=3 AND SZ AND ZF AND DZSJ<=1,POINTDOT,COLORFF00FF;
涨4:COUNT(SZ,4)>=3 AND SZ AND ZF AND DZSJ<=1,POINTDOT,COLOR00FF00;
涨5:COUNT(SZ,5)>=4 AND SZ AND ZF AND DZSJ<=1,POINTDOT,COLORWHITE;
涨6:COUNT(SZ,6)>=5 AND SZ AND ZF AND DZSJ<=1,POINTDOT,COLORFF6600;
涨7:COUNT(SZ,7)>=6 AND SZ AND ZF AND DZSJ<=1,POINTDOT,COLORRED;
涨:涨4 AND NOT(涨5) AND NOT(涨6) AND NOT(涨7),POINTDOT,COLOR00FF00;
跌3:COUNT(XD,3)=3 AND XD AND DF AND DDSJ<=1,POINTDOT,COLORFF00FF;
跌4:COUNT(XD,4)>=3 AND XD AND DF AND DDSJ<=1,POINTDOT,COLOR00FF00;
跌5:COUNT(XD,5)>=4 AND XD AND DF AND DDSJ<=1,POINTDOT,COLORWHITE;
跌6:COUNT(XD,6)>=5 AND XD AND DF AND DDSJ<=1,POINTDOT,COLORFF6600;
跌7:COUNT(XD,7)>=6 AND XD AND DF AND DDSJ<=1,POINTDOT,COLORRED;
底:跌6 AND 跌9,POINTDOT,COLORRED;
{以下设置副图显示方式}
STICKLINE(涨3>0,2,3,4,0),COLORFF00FF;
STICKLINE(涨4>0,3,4,4,0),COLOR00FF00;
STICKLINE(涨5>0,4,5,4,0),COLORWHITE;
STICKLINE(涨6>0,5,6,4,0),COLORFF6600;
STICKLINE(涨7>0,6,7,4,0),COLORRED;
STICKLINE(涨>0,-2,2,4,1),COLORRED;
DRAWTEXT(涨>0,0.3,'涨'),COLOR00FF00;
STICKLINE(跌3>0,-2,-3,4,0),COLORFF00FF;
STICKLINE(跌4>0,-3,-4,4,0),COLOR00FF00;
STICKLINE(跌5>0,-4,-5,4,0),COLORWHITE;
STICKLINE(跌6>0,-5,-6,4,0),COLORFF6600;
STICKLINE(跌7>0,-6,-7,4,0),COLORRED;
STICKLINE(底>0,-2,2,4,1),COLOR00FF00;
DRAWTEXT(底>0,0.3,'底'),COLORRED;
0,COLORYELLOW,LINETHICK1;
4,POINTDOT,COLOR00FF00;
-6,POINTDOT,COLORRED;

通达信涨跌音阶指标公式

 

相关文章