在线检测未来函数

通达信阴阳线主图指标公式

来源:Internet,编辑:股旁网,2013-03-24

X:=(3*C+L+O+H)/6;
阴阳线:(20*X+19*REF(X,1)+18*REF(X,2)+17*REF(X,3)+16*REF(X,4)+15*REF(X,5)+14*REF(X,6)
+13*REF(X,7)+12*REF(X,8)+11*REF(X,9)+10*REF(X,10)+9*REF(X,11)+8*REF(X,12)
+7*REF(X,13)+6*REF(X,14)+5*REF(X,15)+4*REF(X,16)+3*REF(X,17)+2*REF(X,18)+
REF(X,20))/210,COLORFF00FF,LINETHICK2;
机构成本:DMA((C+O+H+L)/4,V/SUM(V,25))COLORYELLOW ;
牛线:=MA(MA(CLOSE,20)+2*STD(CLOSE,15),5),COLORFF8000,LINETHICK1;
金龙:=(EMA(C,15)+EMA(C,30)+EMA(C,60)+EMA(C,120))/4,LINETHICK2;
STICKLINE( C>O ,O , C,2.5,1 ),COLOR0000FF;
STICKLINE(C<O ,O , C,2.5,1 ),COLORFFE600;
F:=100*(C-REF(C,1))/REF(C,1);
P1:=IF(C<REF(O,1) AND F<0,1,0);
P2:=IF(C<REF(O,2) AND F<0,1,0);
STICKLINE(P1=0 AND REF(P1,1)=1 AND P2=0 AND REF(P2,1)=1,OPEN,CLOSE,0.1,0),COLORFFFFFF;
VAR1A:=AMOUNT/10000;
VAR2:=IF(V-REF(V,1)<0,V,0);
VAR3:=SUM((C-REF(C,1))/REF(C,1)*VAR2/1000,0);
A:=VAR3<REF(VAR3,1) AND REF(VAR3,1)<REF(VAR3,2) AND REF(VAR3,2)<REF(VAR3,3);
A1:=CROSS(A,0.5);
DRAWTEXT(A1,L*0.95,'');
{AA1:=AMOUNT/V;
BB1:=L<AA1*0.9;
CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;
DD1:=L<MA(C,5)*0.921;
EE1:=V<MA(V,5)*1.5;
FF1:=BB1 AND CC1 AND DD1 AND EE1;
DRAWTEXT(FF1,L*0.99,'底');}
AA1:=REF(EMA(C,14),1);
A1X:=(EMA(C,14)-AA1)/AA1*100,NODRAW;
CYA:=WINNER(C)*100;
CYB:=EMA(CYA,10);
AS:=CYA-CYB;
A1A:=MA(AS,10);
STICKLINE(CROSS(A1X,0) AND CROSS(AS,A1A),C,O,3,0 ),COLOR6600FF;
STICKLINE(CROSS(A1X,0) AND CROSS(AS,A1A),C,O,2,0 ),COLORAA00FF;
STICKLINE(CROSS(A1X,0) AND CROSS(AS,A1A),C,O,1,0 ),COLOREE00FF;
V2:=IF(CURRBARSCOUNT=1,VOL*240/FROMOPEN/REF(VOL,1)-1,VOL/REF(VOL,1)-1);
STICKLINE(V2>=1,O,C,1,0),COLORYELLOW;
ADD:=V>FINANCE(7)/1000/3;
ADD1:=STICKLINE(V>REF(V,1)*2 AND C>=O,0,V,1,0),COLORYELLOW;
支撑:= REF(L,BARSLAST(ADD1));
STICKLINE(C,REF(L,BARSLAST(ADD1))*0.998,REF(L,BARSLAST(ADD1))*1.003,4,0),COLOR0000FF;
STICKLINE(C,REF(L,BARSLAST(ADD1)),REF(L,BARSLAST(ADD1))*1.001,4,0),COLORYELLOW;
DT:=EMA(CLOSE,1);主力战线A:=EMA(DT,5) ;
主力战线B:=EMA(HHV(主力战线A,5),1);
主力战线C:=EMA(HHV(主力战线B,15),1);
主力战线D:=EMA(HHV(主力战线C,20),2);
主力战线:EMA(HHV(主力战线D,20),3),LINETHICK2, COLORRED;
HD:=FILTER(BACKSET(FILTER(REF(C,10)=HHV(C,2*10+1),10),10+1),10);
LD:=FILTER(BACKSET(FILTER(REF(C,10)=LLV(C,2*10+1),10),10+1),10);
AD:=REF(C,BARSLAST(HD));
B:=REF(C,BARSLAST(LD));
T1:=BARSLAST(HD)<BARSLAST(LD) AND NOT(HD) ;
T2:=BARSLAST(HD)>BARSLAST(LD) AND NOT(LD);
波浪顶:IF(T1,AD,AD),COLOREE00FF,POINTDOT,LINETHICK1;
BL:=STICKLINE(T1,AD,AD*0.998,10,0),COLOREE00FF;
波浪底:=IF(T2,B,B),COLOR80FF00,POINTDOT,LINETHICK1;
强势:=MA(MA(C,20)+2*STD(C,15),5),COLOR555555;
筹:SMA(COST(95),5,1),COLORGREEN;

通达信阴阳线主图指标公式

 

相关文章