在线检测未来函数

通达信多空较量指标公式

来源:Internet,编辑:股旁网,2013-03-24

指标说明: 这是根据三角形面积公式原理计算出多空双方的量进行比较, 粉红色柱表示当天多空相抵的量为正,绿色柱表示为负, 大红虚柱表示累计量在增加, 青色实柱表示累计量在减少, m20大于m20b表示中线增强,反之为减弱, 当累计量上穿中线m20时,表示新一轮行

CB:=IF(CAPITAL>1,AMOUNT/VOL/100,(HIGH+LOW+2*CLOSE)/4);
空1:=IF((HIGH-LOW)>0 AND CLOSE>CB, ((HIGH-CLOSE)/(HIGH-CB))*((HIGH-CLOSE)/(HIGH-CB))*((HIGH-CB)/(HIGH-LOW)*VOL),0);
多1:=IF((HIGH-LOW)>0 AND CLOSE>CB, VOL-空1 ,0);
多2:=IF((HIGH-LOW)>0 AND CLOSE<=CB, ((CLOSE-LOW)/(CB-LOW))*((CLOSE-LOW)/(CB-LOW))*((CB-LOW)/(HIGH-LOW)*VOL),0);
空2:=IF((HIGH-LOW)>0 AND CLOSE<=CB, VOL-多2 ,0);
多3:=IF((HIGH-LOW)=0 AND CLOSE>REF(CLOSE,1), VOL,0);
空3:=IF((HIGH-LOW)=0 AND CLOSE<=REF(CLOSE,1), VOL,0);
多方量:多1+多2+多3,NODRAW,COLORRED;
空方量:空1+空2+空3,NODRAW,COLORGREEN;
多空相抵:多方量-空方量,NODRAW;
MS:=SUM(多空相抵,5);
M20:EMA(SLOPE(MS,21)*20+MS,55)*1,COLORYELLOW,LINETHICK3;
M20B:MA(M20,5),COLORLIMAGENTA,LINETHICK3;
DRAWBAND(M20,RGB(90,0,0),M20B,RGB(0,20,0));
STICKLINE(多空相抵>0,多空相抵,0,2,0),COLORMAGENTA;
STICKLINE(多空相抵<0,0,ABS(多空相抵),2,0),COLORGREEN;
STICKLINE(CURRBARSCOUNT<6,MS,REF(MS,1),2,1),COLORRED;
STICKLINE(CURRBARSCOUNT<6 AND MS<REF(MS,1),MS,REF(MS,1),2,0),COLORCYAN;

通达信多空较量指标公式

 

相关文章