在线检测未来函数

通达信RSI复合通道指标公式

来源:Internet,编辑:股旁网,2013-03-25

M:=5;N1:=3;N2:=3;
LC:=REF(CLOSE,1);
RS1:=SMA(MAX(CLOSE-LC,0),M,1)/SMA(ABS(CLOSE-LC),M,1)*100;
量能:=SMA(MAX(CLOSE-LC,0),N1,1)/SMA(ABS(CLOSE-LC),N1,1)*100;
SM:MA(RS1,20),COLORFF00FF,NODRAW;
SU:SM+2*STD(RS1,20),COLORFFFF00,NODRAW;
SD:SM-2*STD(RS1,20),COLOR00FF00,NODRAW;
TR1:=MA(MAX(MAX((RS1-RS1),ABS(REF(RS1,1)-RS1)),ABS(REF(RS1,1)-RS1)),15);
VM:MA(RS1,N1),COLORFF00FF,NODRAW;
VU:VM+2.3*TR1,COLORFFFFFF,NODRAW;
VD:VM-2.1*TR1,COLOR00FFFF,NODRAW;
DRAWBAND(SU,RGB(0,170,140),SD,RGB(0,170,140));
DRAWBAND(VU,RGB(220,220,220),VD,RGB(220,220,220));
DRAWTEXT(ISLASTBAR AND RSI>REF(RSI,1),VM,27),COLORDD00FF;
DRAWTEXT(ISLASTBAR AND RSI<REF(RSI,1),VM,28),COLORCCEE00;
MA1:MA(RS1,N1),COLOR000000;
MA2:MA(RS1,N2),COLORFF0000,LINETHICK2;
RSI:RS1,COLORRED,LINETHICK2;
短期:=100*(C-LLV(L,5))/(HHV(C,5)-LLV(L,5)),COLORWHITE;
长期:=100*(C-LLV(L,30))/(HHV(C,30)-LLV(L,30)),COLORRED,LINETHICK1;
长短5倍:=DRAWTEXT(长期/短期>5,(50),'5'),COLORFFFF00;
单针二十:=DRAWTEXT(短期<20 AND 长期>55,(80),'2'),COLORFFFF00;
四线小六:=DRAWTEXT(短期<6 AND 100*(C-LLV(L,10))/(HHV(C,10)-LLV(L,10))<6 AND 长期<6,(3),'6'),COLORFFFF00;
DRAWICON(单针二十,RSI*1.05,12);
DRAWICON(四线小六 ,RSI,9);
DRAWICON(长短5倍 ,RSI,15);

通达信RSI复合通道指标公式

 

相关文章