在线检测未来函数

通达信KJ量能指标公式

来源:Internet,编辑:股旁网,2013-03-26

N0:=9;M10:=3;M20:=3;
股:10*(EMA(CLOSE,12)-EMA(CLOSE,26)),COLORGREEN;
董:HHV(股,9),COLORFF00FF;
DRAWBAND(董,RGB(0,224,110),股,0);
玩股:IF(股>REF(股,1),股,DRAWNULL),LINETHICK4,COLORRED;
董涨:=董>REF(董,1);
DRAWICON(董涨,董*0.98,1);
董跌:=董<REF(董,1);
DRAWICON(董跌,董*0.98,2);
股涨:=股>REF(股,1);
DRAWICON(股涨,股*0.98,1);
股跌:=股<REF(股,1);
DRAWICON(股跌,股*0.98,2);
N:= 9 ;
M1 := 3 ;
M2 := 3 ;
M3:= 5 ;
RSV:= (CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
FASTK:=SMA(RSV,M1,1);
K:SMA(FASTK,M2,1),LINETHICK2;
D:SMA(K,M3,1),NODRAW;
J:3*K-2*D,LINETHICK3,COLORWHITE;
IF(J>REF(J,1),J,DRAWNULL),LINETHICK3,COLORRED;
IF(J<REF(J,1),J,DRAWNULL),LINETHICK3,COLORWHITE;
IF(K>REF(K,1),K,DRAWNULL),LINETHICK3,COLORRED;
IF(K<REF(K,1),K,DRAWNULL),LINETHICK3,COLORGREEN;
BB:=COUNT(J<REF(J,1),5)=5;
B:(REF(BB,1) AND J>=REF(J,1) AND J<30)*10,NODRAW;
LB:IF(B,LLV(L,10),0),NODRAW;
DRAWICON(B,J*0.99,1);
BIAS:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
XG:((CROSS(K,D)AND D<16 AND BIAS<-6))*80;
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
VAR1:=HHV(DEA,53);
VAR2:=LLV(DEA,55);
VAR3:=DEA-(DIF-DEA);
UP:=IF(DIF>VAR1 AND DEA=VAR1,MAX(LLV(VAR1,10),VAR3),VAR1);
DN:=IF(DIF<VAR2 AND DEA=VAR2,MIN(HHV(VAR2,10),VAR3),VAR2);
IF(DIF>UP,104,DRAWNULL),LINETHICK2,COLORYELLOW;
IF(DIF<DN,-5,DRAWNULL),LINETHICK2,COLORF00FF0;
DRAWTEXT(DIF>UP,80,'S'),COLORGREEN;
DRAWTEXT(DIF<DN,80,'B'),COLORRED;
100,COLORGREEN,LINETHICK2;
趋势:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
见底:=10;
{短期底部:CROSS(趋势,见底);
DRAWICON(短期底部,短期底部*0.99,1);}
短期底部:STICKLINE(CROSS(趋势,见底),0,40,1.5,0),COLORRED;
DRAWTEXT(CROSS(趋势,见底),10,'底部'),COLOR00FFFF;
RSV0:=(CLOSE-LLV(LOW,N0))/(HHV(HIGH,N0)-LLV(LOW,N0))*10;
K0:SMA(RSV0,M10,1),LINETHICK2,NODRAW;
D0:SMA(K0,M20,1),LINETHICK2,NODRAW;
J0:3*K0-2*D0,LINETHICK2,NODRAW;
KDJ10:=REF(COUNT(J0<REF(J0,1),5)>=3,1) AND REF(J0,1)<15;
KDJ20:=J0>REF(J0,1);
反转:IF(FILTER(KDJ10 AND KDJ20,3),40,0),COLORFF9900,LINETHICK2;
LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),4,1)/SMA(ABS(CLOSE-LC),4,1)*100;
VARB:=SMA(MAX(CLOSE-LC,0),7,1)/SMA(ABS(CLOSE-LC),7,1)*100;
VARC:=SMA(MAX(CLOSE-LC,0),13,1)/SMA(ABS(CLOSE-LC),13,1)*100;
VARD:=BARSCOUNT(CLOSE);
底部雷达:(VARB< 20 AND VARC< 30 AND VARD> 20)*60,LINETHICK1,COLORYELLOW;
RSV55:=(CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100;
K055:=SMA(RSV55,3,1);
K55:=K055;D55:=SMA(K055,2,1);
多头:(3*K055-2*D55),LINETHICK2,NODRAW;
多势:MA(多头,2),LINETHICK2,NODRAW;
MAV:=(2*C+H+L)/4;
VAR155:=LLV(LOW,21);
VAR255:=HHV(HIGH,21);
能量: EMA((MAV-VAR155)/(VAR255-VAR155)*100,8),NODRAW;
动量: EMA(0.667*REF(能量,1)+0.333*能量,1),NODRAW;
SJ:=3*能量-2*动量;
平衡:50,POINTDOT,COLORFF9999,LINETHICK2;
风险:70,POINTDOT,COLORF0F000,LINETHICK2;
卖出:90,COLORWHITE,LINETHICK1;
底部:(SJ<18)*10,COLORYELLOW,LINETHICK1;
攻击:=IF(底部,0,20),LINETHICK2,COLORYELLOW;
DRAWTEXT(CROSS(多头,能量) AND 50>多头 ,多头-5,'买'),COLORYELLOW,LINETHICK2;
DRAWTEXT(CROSS(多势,多头) AND 多头>80,多头+6,'卖'),COLOR00FF00,LINETHICK2;
DRAWTEXT(CROSS(卖出,多头) AND 多头>风险,多头+18,'逃'),COLORFFFF00,LINETHICK2;
DRAWTEXT(CROSS(多头,攻击) AND 多头>能量,多头-10,'短追'),COLORWHITE,LINETHICK2;

通达信KJ量能指标公式

 

相关文章