在线检测未来函数

通达信狂牢天雷指标公式

来源:Internet,编辑:股旁网,2013-03-29

N:=55;N2:=13;
VAR1:=(HHV(HIGH,9)-CLOSE)/(HHV(HIGH,9)-LLV(LOW,9))*100-70;
VAR2:=SMA(VAR1,9,1)+100;
VAR3:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VAR4:=SMA(VAR3,3,1);
VAR5:=SMA(VAR4,3,1)+100;
VAR6:=VAR5-VAR2;
S: IF(VAR6>n,VAR6-n,0);
STICKLINE(REF(S,1)<S,S,REF(S,1),5,0),coloryellow;
STICKLINE(REF(S,1)>S,S,REF(S,1),5,0),colorff00ff;
v1:=(2*CLOSE+HIGH+LOW)/4;
v2:=LLV(LOW,13);
v3:=HHV(HIGH,13);
v4:=EMA((v1-v2)/(v3-v2)*100,13);
v5:=EMA(0.667*REF(v4,1)+0.333*v4,2);
STICKLINE(v4>v5,v4,v5,4,1),COLORRED;
STICKLINE(v4<=v5,v4,v5,4,1),COLOR00ff00;
bar1:=LLV(LOW,5)=LLV(LOW,45) AND CLOSE>=OPEN*1.04;
底部吸筹指标:=(CLOSE-MA(CLOSE,40))/MA(CLOSE,40)*100*bar1;
波段底部:IF(CROSS(底部吸筹指标,-24),0,30)*bar1, COLORYELLOW;
VarE:=30+(REF(CLOSE,1)-REF(OPEN,1))/REF(OPEN,1)*100/1.5;
VarF:=30+(REF(CLOSE,2)-REF(OPEN,2))/REF(OPEN,2)*100/1.5;
Var10:=CROSS("KDJ.K"(9,3,3),"KDJ.J"(9,3,3)) AND "KDJ.D"(9,3,3)>N2;
Var11:=CROSS(REF("KDJ.K"(9,3,3),1),REF("KDJ.J"(9,3,3),1)) AND REF("KDJ.D"(9,3,3),1)>N2;
Var12:=CROSS(REF("KDJ.K"(9,3,3),2),REF("KDJ.J"(9,3,3),2)) AND REF("KDJ.D"(9,3,3),2)>N2;
Var13:=Var10 OR Var11 OR Var12;
Var14:=REF("BIAS.BIAS2"(6,12,24),1)>2;
Var15:=REF("RSI.RSI1"(6,12,24),1)>(VarE+VarF)/1.8 AND REF("ROC.ROC"(12,6),1)-"ROC.ROC"(12,6)>0 AND Var13 AND Var14;
卖出:=Var15*100/15,color00ff00;
STICKLINE(卖出,80,78,6,0),color00ff00;

通达信狂牢天雷指标公式

 

相关文章