在线检测未来函数

通达信未来看五线主图指标公式

来源:Internet,编辑:股旁网,2013-03-30

A1:=MA(MAX(HHV(H,13),C),2);
A2:=MA(MAX(HHV(H,5),A1),2);
A3:=MA(MAX(HHV(H,3),A2),2);
A4:=MA(MIN(LLV(A3,13),A3),2);
A5:=MA(MIN(LLV(L,13),A4),2);
A6:=(A1+A4+A5)/3;
中线:EMA(SLOPE(MA(C,2),21)*20+MA(C,2),55),COLORGREEN,LINETHICK3;
长线:MA(中线,20);
AC:=IF(C>中线,C*0.98,L),COLORYELLOW;
短A:MA(AC,5);
A8:=IF(C>中线,A1,中线*1.02);
A9:=IF(C>中线,A2,中线*1.02);
A10:=IF(C>中线,A3,中线*1.02);
A11:=(A8+A9+A10)/3;
A12:=MA(A11,10);
短B:MA(短A,5),COLORYELLOW;
DRAWTEXT(CROSS(C,短B),短B,'★'),COLORRED;
DRAWTEXT(CROSS(C,中线),中线,'★'),COLORRED;
DRAWTEXT(CROSS(C,长线),长线,'★'),COLORRED;
箱顶:HHV(MA((LOW+HIGH+CLOSE+OPEN)/4,5),58),COLOR00AAFF;
箱底:=LLV(MA((LOW+HIGH+CLOSE+OPEN)/4,6),58),COLOR00FF00,CIRCLEDOT;
DRAWTEXT_FIX(1,0.08,0.05,1,'股价上穿短B'),COLORYELLOW;
DRAWTEXT_FIX(1,0.18,0.05,1,'股价上穿中线'),COLORYELLOW;
DRAWTEXT_FIX(1,0.28,0.05,1,'股价上穿长线'),COLORYELLOW;
DRAWTEXT_FIX(1,0.42,0.05,1,'股价收阳且小于3点'),COLORYELLOW;
DRAWTEXT_FIX(1,0.52,0.05,1,'量大于昨同期'),COLORYELLOW;
DRAWTEXT_FIX(1,0.63,0.05,1,'乖离率小于1.2'),COLORYELLOW;
DRAWTEXT_FIX(1,0.72,0.05,1,'买入评分'),COLORYELLOW;
DRAWTEXT_FIX(1,0.08,0.15,1,'股价下穿短A'),COLORGREEN;
DRAWTEXT_FIX(1,0.18,0.15,1,'股价下穿中线'),COLORGREEN;
DRAWTEXT_FIX(1,0.28,0.15,1,'股价下穿长线'),COLORGREEN;
DRAWTEXT_FIX(1,0.41,0.15,1,'股价收阴且小于-2'),COLORGREEN;
DRAWTEXT_FIX(1,0.52,0.15,1,'量小于昨同期'),COLORGREEN;
DRAWTEXT_FIX(1,0.63,0.15,1,'乖离率大于1.2'),COLORGREEN;
DRAWTEXT_FIX(1,0.72,0.15,1,'卖出评分'),COLORGREEN;
T1:=CROSS(C,短B)AND EXIST(CROSS(中线,C),5);DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.08,0.10,1,T1);
T2:=CROSS(C,中线);DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.18,0.10,1,T2);
T3:=CROSS(C,长线);DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.28,0.10,1,T3);
T4:=C>REF(C,1) AND C/REF(C,1)<1.031;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.41,0.10,1,T4);
T5:=V>REF(V,1)*FROMOPEN/240;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.52,0.10,1,T5);
T6:=C/中线<1.21;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.61,0.10,1,T6);
买入评分:=T1+T2+T3+T4+T5+T6;
STICKLINE(CURRBARSCOUNT=1 AND C>REF(C,1),C,中线,3,1),COLORRED;
STICKLINE(CURRBARSCOUNT=1 AND C>REF(C,1),长线,中线,2,0),COLORYELLOW;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.71,0.10,1,买入评分),COLORRED;
DRAWRECTREL(930,500,970,990,0);
DRAWRECTREL(930,CONST(990-买入评分*100),970,990,95);
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.95,0.95,1,买入评分),COLORRED;
DRAWTEXT_FIX(1,0.98,0.75,1,'买入评分'),COLORYELLOW;
T7:=CROSS(短A,C);DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.08,0.20,1,T7);
T8:=CROSS(中线,C);DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.18,0.20,1,T8);
T9:=CROSS(中线,C);DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.28,0.20,1,T9);
T10:=C/REF(C,1)<0.98;DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.41,0.20,1,T10);
T11:=V<REF(V,1)*FROMOPEN/240;DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.52,0.20,1,T11);
T12:=C/中线>1.2;DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.63,0.20,1,T12);
卖出评分:=T7+T8+T9+T10+T11+T12;DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.71,0.20,1,卖出评分);
量比前1:=V/(REF(V,1)*FROMOPEN/240);
DRAWTEXT_FIX(1,0.72,0.95,1,'量比前1'),COLORYELLOW;
DRAWNUMBER_FIX(CURRBARSCOUNT=1 AND 量比前1>=1 ,0.78,0.95,1,量比前1),COLORRED;
DRAWNUMBER_FIX(CURRBARSCOUNT=1 AND 量比前1<1 ,0.78,0.95,1,量比前1),COLORWHITE;

通达信未来看五线主图指标公式

 

相关文章