在线检测未来函数

通达信百万焰火指标公式

来源:Internet,编辑:股旁网,2013-04-01

EMA30:EMA(C,30),COLORWHITE,LINETHICK2;
EMA60:EMA(C,60),COLORFF00FF;
EMA90:EMA(C,90),COLORYELLOW;
EMA120:EMA(C,120),COLORFFCC66;
EMA250:EMA(C,250),COLORBLUE;
SS:=CROSS(EMA30,EMA60) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018
OR CROSS(EMA30,EMA120) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018
OR CROSS(EMA60,EMA90) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018
OR CROSS(EMA30,EMA90) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018 {AND CROSS(EMA30,EMA120)};
DRAWICON(SS,L-0.04,1);
DD:=CROSS(EMA60,EMA90) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018
OR CROSS(EMA60,EMA250) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018
OR CROSS(EMA90,EMA120) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018
OR CROSS(EMA60,EMA120) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018 AND CROSS(EMA30,EMA250);
{DD:=CROSS(EMA30,EMA250);}
DRAWICON(DD,L-0.04,3);80,COLORRED;
20;
VAR1:=HHV(HIGH,9)-LLV(LOW,9);
VAR2:=HHV(HIGH,9)-C;
VAR3:=C-LLV(LOW,9);
VAR4:=VAR2/VAR1*100-70;
VAR5:=(C-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;
VAR6:=(2*C+H+L)/4;
VAR7:=SMA(VAR3/VAR1*100,3,1);
VAR8:=LLV(LOW,34);
VAR9:=SMA(VAR7 ,3 ,1 )-SMA(VAR4 ,9 ,1);
VAR10:=IF(VAR9>100 ,VAR9-100 ,0 );
VAR11:=HHV(HIGH,34);
VAR12:=EMA((VAR6- VAR8)/(VAR11-VAR8)*100,13 );
VAR13:=EMA(0.667*REF(VAR12 ,1) +0.333*VAR12,2 );
VAR13,COLORRED;
STICKLINE(VAR12-VAR13 >0,VAR12 ,VAR13 ,8 ,0 ),COLOR00FF0F;
STICKLINE(VAR12-VAR13 <0,VAR12 ,VAR13 ,8 ,0),COLORRED;
差值:=(VAR12-VAR13)*5;
STICKLINE( 差值>=0 ,0 ,差值 ,4 ,0 ),COLORYELLOW;
Var101:=SMA(100*(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34)),3,1);
Var102:=IF(Var101<20,Var101*3.5,0);
IF(Var102>20,Var102*1.04,0), STICK, COLORRED,linethick2;
IF(Var102>20,Var102*1.06,0), STICK ,COLORYELLOW,linethick2 ;
IF(Var102>20,Var102*1.08,0), STICK, COLORGREEN,linethick2;
IF(Var102>20,Var102*1.01,0), STICK, COLORRED,linethick2;
STICKLINE(Var102>=0,0,Var102*1,4,0), COLORRED ;
STICKLINE(Var102>=0,0,Var102*0.8,4,0), COLOR0000ff ;
STICKLINE(Var102>=0,0,Var102*0.6,4,0), COLOR0066ff ;
STICKLINE(Var102>=0,0,Var102*0.4,4,0), cOLOR0099ff ;
STICKLINE(Var102>=0,0,Var102*0.2,4,0), COLORyellow;

通达信百万焰火指标公式

 

相关文章