在线检测未来函数

通达信新创DMI指标公式

来源:Internet,编辑:股旁网,2013-04-03

A1:=EXPMEMA(MAX(MAX(H-L,ABS(H-REF(C,1))),ABS(REF(C,1)-L)),10);
A2:=H-REF(H,1);
A3:=REF(L,1)-L;
A4:=EXPMEMA(IF(A2>0 AND A2>A3,A2,0),10);
A5:=EXPMEMA(IF(A3>0 AND A3>A2,A3,0),10);
A6:A4*100/A1,COLORYELLOW,LINETHICK3;
A6M5:=MA(A6,5);
A7:=A5*100/A1;
A8:EXPMEMA(ABS(A6-A7)/(A6+A7)*100,6),COLORRED,LINETHICK3;
A9:=EXPMEMA(A8,5);
DRAWBAND(A8,RGB(192,14,235),A9,RGB(47,79,79));
DRAWBAND(A6,125,A6M5,30);
A10:MA(A7,5),COLORGREEN,LINETHICK3;
B1:=(C-O)/(H-L)*V;
B2:=(H-C)/(H-L)*V;
B3:=(O-L)/(H-L)*V;
当日上攻量:=B1*0.7+B2*0.5+B3*0.4,VOLSTICK;
当日出货量:=A1*0.3+A2*0.5,NODRAW,COLORGREEN;
当日杀跌量:=B3*0.6,NODRAW,COLORBLUE;
五日上攻量:=SUM(当日上攻量,5),COLORRED;
五日出货量:=SUM(当日出货量,5),COLORGREEN,LINETHICK2;
五日杀跌量:=SUM(当日杀跌量,5),COLORBLUE,LINETHICK2;
多方占%:五日上攻量/SUM(V,5)*100,COLORRED,NODRAW;
空方占%:(五日出货量+五日杀跌量)/SUM(V,5)*100,NODRAW;
STICKLINE(CURRBARSCOUNT=8,79,79.5,多方占%,0),COLORRED;
STICKLINE(CURRBARSCOUNT=8,78.9,78.4,空方占%,0),COLORGREEN;

通达信新创DMI指标公式

 

相关文章