在线检测未来函数

通达信天圆地方主图指标公式

来源:Internet,编辑:股旁网,2013-04-05

P1:=3;P2:=5;P3:=7;P4:=9;
MA1:MA(CLOSE,P1);
MA2:MA(CLOSE,P2);
MA3:=MA(CLOSE,P3);
MA4:MA(CLOSE,P4);
ma5:=ema(c,13);
ma6:=sma(c,9,4);
MA7:MA(C,60);
X:=EMA(((SLOPE(CLOSE,21) * 20) + CLOSE),68);
Y:=EMA(CLOSE,10);
LL:=REF(CLOSE,2);
MM:=((SMA(MAX((CLOSE - LL),0),6,1) / SMA(ABS((CLOSE - LL)),6,1)) * 100);
DB:=IF(((MM < REF(MM,1)) AND (MM > 79)),MM,0);
DRAWTEXT(CROSS(Y,X),(LOW * 0.985),'▲'),LINETHICK2;
DRAWTEXT(CROSS(X,Y),(HIGH * 1.015),'◆'),LINETHICK2,colorFF6699;
DRAWTEXT(DB,(HIGH * 1.015),'○'),LINETHICK2,colorFFCC99;
VAR1:=LLV(LOW,21);
VAR2:=HHV(HIGH,21);
AK1:=EMA((((CLOSE - VAR1) / (VAR2 - VAR1)) * 100),5);
AK:=EMA((((CLOSE - VAR1) / (VAR2 - VAR1)) * 50),13);
DD:=EMA(((0.667 * REF(AK1,1)) + (0.333 * AK1)),2);
VAR3:=LLV(LOW,55);
VAR4:=HHV(HIGH,34);
VAR5:=EMA((((CLOSE - VAR3) / (VAR4 - VAR3)) * 100),3);
VAR6:=((AK + VAR5) / 2);
VAR7:=EMA(((0.667 * REF(VAR5,1)) + (0.333 * AK1)),2);
VAR8:=EMA(VAR6,5);
BB:=EMA(((0.667 * REF(VAR8,1)) + (0.333 * VAR8)),2);
AB:=CROSS(AK1,AK);
BB1:=(CROSS(AK1,BB) AND (BB < 30));
CD:=(BB1 * 0.6);
DRAWTEXT((CD = 0.6),(LOW * 0.99),'□'),LINETHICK2,colorFFFFFF;
DRAWTEXT((AB = 1),(LOW * 0.99),'■'),LINETHICK2,color33CC99;
zp:=(CLOSE-LLV(CLOSE,5))/(HHV(CLOSE,5)-LLV(CLOSE,5))*100;
DRAWICON(CROSS(zp,12),l-0.05,1);
drawicon(cross("kdj.k"(5,3,3),"kdj.d"(5,3,3)) and "kdj.k"(5,3,3)<30,l*0.96,4);
drawicon(cross(ma5,ma6) and cross("kdj.k"(5,3,3),"kdj.d"(5,3,3)) and "kdj.k"(5,3,3)<30,l*0.98,4);
drawtext(cross("kdj.k"(5,3,3),"kdj.d"(5,3,3)) and "kdj.k"(5,3,3)<30,l*0.995,'←买入'),coloryellow;
stickline(cross(ma5,ma6) and "kdj.k"(5,3,3)>=50 and "kdj.j"(5,3,3)<31 ,l*0.82,l*0.90,12,1),colormagenta;
drawtext(cross(ma5,ma6) and "kdj.k"(5,3,3)>=50 and "kdj.j"(5,3,3)<31 ,l*0.92,'←再买'),coloryellow;
drawtext(cross(84,"rsi.rsi1") or cross(ma2,ma1) , h*1.01 ,'○'),colormagenta;

通达信天圆地方主图指标公式

 

相关文章