在线检测未来函数

通达信淡定一号+选股指标公式

来源:Internet,编辑:股旁网,2013-04-09

N:=5;
BB:=REF(CLOSE,N);
CC:=SMA(MAX(CLOSE-BB,0),2,1)/SMA(ABS(CLOSE-BB),2,1)*100-50;
DIFF:=(EMA(CLOSE,12)-EMA(CLOSE,26))*500/EMA(CLOSE,26);
DEA:=EMA(DIFF,9);MACD:=2*(DIFF-DEA);
DRAWBAND(-40,RGB(5,100,50),CC,0);
{以下为显示}
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,0,2,0),COLORDDDD00;
STICKLINE(MACD<REF(MACD,1)AND MACD<0,0,0,2,0)COLOR00DD00;
STICKLINE(MACD>REF(MACD,1)AND MACD,0,0,2,0),COLOR00DDEE;
STICKLINE(MACD>REF(MACD,1)AND MACD>0,0,0,2,0),COLOR0000DD;
线:CC,COLOR0099CC;
蓝天:STICKLINE(C,40,40,0.5,0.5),COLOREEEE00;
绿地:STICKLINE(C,-40,-40,0.5,0.5),COLOR00EE00;
涨家数:INDEXADV,COLOR0000EE,NODRAW;
跌家数:INDEXDEC,COLOR00EE00,NODRAW;
大盘成交:INDEXV,COLOR00EEEE,NODRAW;

{
选股公式:

N:=5;
BB:=REF(CLOSE,N);
CC:=SMA(MAX(CLOSE-BB,0),2,1)/SMA(ABS(CLOSE-BB),2,1)*100-50;
DIFF:=(EMA(CLOSE,12)-EMA(CLOSE,26))*500/EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
XG:CC>49 AND DIFF>0 AND DEA>0 AND REF(C,1)/REF(C,2)<1 AND REF(O,1)>REF(C,1) AND C>REF(C,1) AND C>O AND MA(C,5)>MA(C,10) AND MA(C,10)>MA(C,20) AND MA(C,20)>MA(C,60);
}

通达信淡定一号+选股指标公式

 

相关文章