在线检测未来函数

通达信股道换手统计指标公式

来源:Internet,编辑:股旁网,2013-04-10

P换手:=15;
DRAWGBK(C>0, RGB(0,0,00),RGB(0,0,0),0,'012',0);
重心线:0.01*AMOUNT/VOL,LINETHICK2,COLORRED;
MA5:MA(C,5),LINETHICK1;
中期方向线:EXPMA(C,12)-EXPMA(C,50),NODRAW;
F:=MOD(SUM(100*VOL/CAPITAL,0),100);
M:=(SUM(100*VOL/CAPITAL,0)-F)/100,LINETHICK0;
TJ:=F<REF(F,1),LINETHICK0;
FD:=REF(BARSLAST(TJ),1)+1,LINETHICK0;
DRAWTEXT(TJ,重心线*0.96,'▲换!'),COLORYELLOW,LINETHICK3;
STICKLINE(TJ,重心线,重心线*0.98,0.08,0),COLOR0000FF,LINETHICK1;
N:=REF(中期方向线,1)<0 AND 中期方向线>=0;{信号点}
AC:=IF(中期方向线<0,0,BARSLAST(N));
HSL:100*VOL/CAPITAL,NODRAW,COLORLIGREEN;
DRAWTEXT(N,重心线*0.93,'▲中红'),COLORRED;
STICKLINE(N,重心线,重心线*0.98,0.02,0),COLOR00FFFF,LINETHICK1;
TZHSL:=SUM(HSL,AC);
TZHSL1:=SUM(HSL,1);
TZHSL2:=SUM(HSL,2);
TZHSL3:=SUM(HSL,3);
TZHSL5:=SUM(HSL,5);
TZHSL10:=SUM(HSL,10);
TZHSL20:=SUM(HSL,20);
TZHSLN:=SUM(HSL,P换手);
TZHSLJL:=SUM(HSL,FD);
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.01,0.30,0,'■中红至今换手率:'),COLORFFCC99;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.14,0.30,0,' %---中期天数为0无效'),COLORFFCC99;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.10,0.30,0,TZHSL),COLORRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.01,0.40,0,'■起点至今天数:'),COLORFFCC99;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.14,0.40,0,' 天---中期方向变红'),COLORFFCC99;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.10,0.40,0,AC),COLORRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.01,0.10,0,'■ 重 心 价:'),COLORFFCC99;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.14,0.10,0,' 元--- -金和量的比'),COLORFFCC99;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.10,0.10,0,重心线),COLORRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.01,0.20,0,'■ 5 日 价 格:'),COLORFFCC99;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.14,0.20,0, ' 元'),COLORFFCC99;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.10,0.20,0,MA5),COLORRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.83,0.05,0,'■今日换手率:'),COLORRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.96,0.05,0,'%'),COLORFFCC99;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.92,0.05,0,TZHSL1),COLORRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.83,0.15,0,'■2日换手率:'),COLORBROWN;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.96,0.15,0,'%'),COLORFFCC99;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.92,0.15,0,TZHSL2),COLORBROWN;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.83,0.25,0,'■3日换手率:'),COLORLIGREEN;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.96,0.25,0,'%'),COLORFFCC99;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.92,0.25,0,TZHSL3),COLORLIGREEN;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.83,0.35,0,'■5日换手率:'),COLORRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.96,0.35,0,'%'),COLORFFCC99;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.92,0.35,0,TZHSL5),COLORRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.83,0.45,0,'■10日换手率:'),COLORBROWN;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.96,0.45,0,'%'),COLORFFCC99;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.92,0.45,0,TZHSL10),COLORBROWN;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.83,0.55,0,'■20日换手率:'),COLORLIGREEN;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.96,0.55,0,'%'),COLORFFCC99;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.92,0.55,0,TZHSL20),COLORLIGREEN;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.83,0.75,0,'■上次到目前换手率:'),COLORRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.96,0.75,0,'%'),COLORFFCC99;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.92,0.75,0,TZHSLJL),COLORRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.83,0.85,0,'■一次换手率天数:'),COLORFFCC99;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.96,0.85,0,'天'),COLORFFCC99;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.92,0.85,0,FD),COLORRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.40,0.00,0,'■N换手率 :'),COLORFFCC99;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.50,0.00,0,'%'),COLORFFCC99;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.46,0.00,0,TZHSLN),COLORRED;

通达信股道换手统计指标公式

 

相关文章