在线检测未来函数

通达信最后防线指标公式

来源:Internet,编辑:股旁网,2013-04-11

N:=5;
Var1:=HHV(HIGH,9)-LLV(LOW,9);
Var2:=HHV(HIGH,9)-CLOSE;
Var3:=CLOSE-LLV(LOW,9);
Var4:=Var2/Var1*100-70;
Var5:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;
Var6:=(2*CLOSE+HIGH+LOW)/4;
Var7:=SMA(Var3/Var1*100,3,1);
Var8:=LLV(LOW,34);
Var9:=SMA(Var7,3,1)-SMA(Var4,9,1);
VarA:=IF(Var9>100,Var9-100,0);
VarB:=HHV(HIGH,34);
AA:= VarA*2;
BB:= EMA((Var6-Var8)/(VarB-Var8)*100,13);
VarC:=EMA(0.667*REF(BB,1)+0.333*BB,2);
CC:= SMA(Var5,20,1);
VarD:=SMA(AA,2,1)-AA;
VarE:=EMA(0.667*REF(BB,1)+0.333*BB,2)-BB;
VAR1a:=(HHV(HIGH,9)-CLOSE)/(HHV(HIGH,9)-LLV(LOW,9))*100-70;
VAR2a:=SMA(VAR1a,9,1)+100;
VAR3a:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VAR4a:=SMA(VAR3a,3,1);
VAR5a:=SMA(VAR4a,3,1)+100;
VAR6a:=VAR5a-VAR2a;
最后防线: IF(VAR6a>n,VAR6a-n,0),ColorFFFFFF;
LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
e:=CROSS(83,RSI);
STICKLINE( e,e,55,1,0),Color00FFFF;
DRAWTEXT(e,50,' 逃顶'),COLORff9966;
STICKLINE(REF(最后防线,1)<最后防线,最后防线,REF(最后防线,1),5,0),colorff00ff;
STICKLINE(REF(最后防线,1)>最后防线,最后防线,REF(最后防线,1),5,0),colorffcc66;
K:sma(SMA((C-LLV(L,80))/(HHV(H,80)-LLV(L,80))*100,10,1),10,1),linethick1,color0000FF;
D:sma(SMA((C-LLV(L,80))/(HHV(H,80)-LLV(L,80))*100,10,1),10,3),linethick2,colorffcc66;

通达信最后防线指标公式

 

相关文章