在线检测未来函数

通达信仙人筹码标公式

来源:Internet,编辑:股旁网,2013-04-11

主筹估算:EMA(WINNER(C)*70,3),LINETHICK2,COLORRED;
散筹估算:EMA((WINNER(C*1.1)-WINNER(C*0.9))*70,3),LINETHICK1,COLORGREEN;
筹码锁定:散筹估算-主筹估算,{COLORFFBB00}COLORGRAY,LINETHICK2;
动态底部:EMA(IF(L<= LLV(L,99),SMA(ABS(L-REF(L,1)),99,1)/SMA(MAX(L-REF(L,1),0),99,1),0)*5,3),COLORYELLOW;
STICKLINE(动态底部>0,0,动态底部,4,0),COLORYELLOW;
STICKLINE(筹码锁定>0,筹码锁定,散筹估算,4,0),COLOR009900;
STICKLINE(筹码锁定<=0,0,散筹估算,4,0),COLOR009900;
STICKLINE(筹码锁定>0,0,筹码锁定,4,0),COLORFFBB00;
STICKLINE(筹码锁定<0,0,筹码锁定,4,0),COLORFFBB00;
主筹估算,LINETHICK2,COLORRED;
涨:=CROSS(主筹估算,筹码锁定),COLORWHITE;
强:=CROSS(主筹估算,散筹估算),COLORYELLOW;
STICKLINE(涨,0,筹码锁定,4,0),COLORWHITE;
STICKLINE(强,0,散筹估算,4,0),COLORYELLOW;
{能量顶底}
{看到红十字卖出,红十字,横线为超买;红十字竖线为能量背离。}
VAR1:=REF(CLOSE,2);
AA2:SMA(MAX(CLOSE-VAR1,0),7,1)/SMA(ABS(CLOSE-VAR1),7,1)*100,COLORYELLOW,LINETHICK2;
超卖1:=IF(AA2<12,30,0),COLORF00FF0;
超卖11:=超卖1;
{STICKLINE(超卖1,0,30,5,0),COLORF00FF0;}
VAR2:=REF(CLOSE,1);
VAR3:=SMA(MAX(CLOSE-VAR2,0),7,1)/SMA(ABS(CLOSE-VAR2),7,1)*100;
超卖2:=IF(VAR3<12,30,0);
超卖22:=超卖2;
{LJL07:=(3*C+L+O+H)/6;}
STICKLINE(超卖2,0,30,5,0),COLORYELLOW;
逢高派发区: STICKLINE(AA2>80,AA2-2,AA2-4,8,0), COLORMAGENTA; {DRAWTEXT(逢高派发区,AA2*1.2,'!'),COLORGREEN;}
牛吃饱走了:=AA2< REF(AA2,1) AND AA2>79;
STICKLINE(牛吃饱走了,0,50,0.5,0),COLORRED;
DRAWICON(牛吃饱走了,60,14);DRAWTEXT(牛吃饱走了,60,'牛饱');
OBV:=SUM(IF(CLOSE>REF(CLOSE,1),VOL,IF(CLOSE<REF(CLOSE,1),-VOL,0)),0)/100000;
A1:=OBV-REF(OBV,1);
A:=MA(OBV,5);
B:=REF(A,1);
B5:=A1/B*10;
C1:=(B5-REF(B5,1))/REF(B5,1);
RSV2:=(CLOSE-LLV(LOW,36))/(HHV(HIGH,36)-LLV(LOW,36))*100;
K:=SMA(RSV2,5,1);
D:=SMA(K,3,1);
PP:=BARSLAST(H=HHV(H,20));
P2:=IF(H=HHV(H,20) OR PP<3,1,0);
P1:=BARSLAST(CROSS(C1,0.5));
VAR13:=(LOW+HIGH+CLOSE)/3;
CB:= MA(VAR13,5);
A5:= HHV(CB,20);
A2:= HHV(CB,60);
B1:= LLV(CB,20);
B2:= LLV(LOW,60)*1.02;
A3:= HHV(HIGH,60)*0.98;
短顶:REF(C1,1)>0.5 AND C1<REF(C1,1) AND H>REF(H,1) AND K>30 AND K>D,COLORYELLOW;
TY:=IF(C1<-8 OR H/LLV(L,3)>1.5,1,0);
STICKLINE(短顶,100,85,2,0),COLORYELLOW;
单阳背离:=C1<0 AND C1=LLV(C1,13) AND C>O AND TY=1;
TU1:=IF((A5>REF(A5,1) AND REF(A5,1)>REF(A5,2) )OR (REF(A5,1)<REF(A5,2) AND REF(A5,2)<REF(A5,3)),1,0);
TU:=IF((C1<0 AND REF(C1,1)>0 AND REF (C1,2)<0 AND COUNT(C>O,3)=3 AND L>REF(L,1) AND REF(L,1)>REF(L,2) ) OR (C1<0 AND C1<REF(C1,1)
AND REF(C,1)>REF(O,1) AND REF(C,2)>REF(O,2) AND REF(C,3)>REF(O,3) AND REF(L,1)>REF(L,2) AND REF(L,2)>REF(L,3)),1,0),COLORLIGREEN;
三阳背离: TU=1 AND K>D AND TU1=1;
STICKLINE(三阳背离,75,95,2,0),COLORLIGREEN;
逃顶:K>80 AND K>D AND CROSS(-0.5,C1) AND P1<5 AND P2=1,COLORGRAY;
STICKLINE(逃顶,20,50,2,0),COLORGRAY;
顶:=K>80 AND CROSS(D,K) AND CROSS(-0.5,C1) AND P1<5 AND P2=1;
VAR11:=REF(CLOSE,1);
VAR12:=SMA(MAX(CLOSE-VAR11,0),6,1)/SMA(ABS(CLOSE-VAR11),6,1)*100;
卖出:= CROSS(80,VAR12);
STICKLINE(卖出,80,100,2,0),COLORCYAN;
强势:=21,COLORMAGENTA; 超强:58,COLORBROWN;
生命量能1:=EMA(400*(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34)),3)/4;
生命量能:生命量能1, STICK,COLORRED;
{DRAWICON(生命量能>=AA2 ,生命量能,6);}
{DRAWICON(生命量能<AA2*0.8 AND 生命量能>=40 AND MA(C,20)>=REF(MA(C,20),1) AND AA2>=REF(AA2,1),生命量能*0.8,15);}
{ DRAWTEXT(FILTER( CROSS(80,VAR12),10),70,'卖');}
DRAWICON(CROSS(80,VAR12),60,16);
VAR55:=LLV(LOW,6);
VAR66:=HHV(HIGH,6);
VAR77:=(VAR66-VAR55)/10;
VAR88:=SMA((CLOSE-VAR55)/VAR77,20,1);
VARA:=3*VAR88-2*SMA(VAR88,3,1);
AA:=MA(EMA(WINNER(C),3),3);
筹码集中度:AA-0.5,COLORYELLOW;
DRAWBAND(筹码集中度,RGB(155,50,50),0,RGB(83,135,68));
STICKLINE(筹码集中度>=0.4,0.4,筹码集中度,4,1),COLORCYAN;
STICKLINE(筹码集中度<=-0.4,-0.4,筹码集中度,4,1),COLORLIGRAY;
中线:EMA(AA-0.5,55),LINETHICK2,COLORLIGRAY;
IF(中线>REF(中线,1),中线,DRAWNULL),LINETHICK2,COLORMAGENTA;
IF(筹码集中度>=REF(筹码集中度,1),筹码集中度,DRAWNULL),COLORRED;
IF(筹码集中度<REF(筹码集中度,1),筹码集中度,DRAWNULL),COLORCYAN;
AB:=EMA(AA-0.5,6);
AC:=CROSS(AA-0.5,AB) AND AB<=-0.3;
AD:=CROSS(AB,AA-0.5) AND AB>=0.35;
DRAWICON(AC,AB,7);
DRAWICON(AD,AB,8);
VAR6:=(2*CLOSE+HIGH+LOW)/4;
VAR7:=LLV(LOW,13);
VAR8:=HHV(HIGH,13);
VAR9:=EMA((VAR6-VAR7)/(VAR8-VAR7)*100,13);
仙人:=(EMA(0.382*REF(VAR9,2)+0.618*VAR9,6)-50)/100;
AAA:=EMA(仙人,3);
{DRAWICON(仙人>=REF(仙人,1) AND REF(仙人,1)<=REF(仙人,2),仙人*0.99,24);}
{DRAWICON(仙人<=REF(仙人,1) AND REF(仙人,1)>=REF(仙人,2),仙人*1.05,2);}
IF(仙人>REF(仙人,1),仙人,DRAWNULL),COLORRED,LINETHICK2;
IF(仙人<REF(仙人,1),仙人,DRAWNULL),COLORCYAN,LINETHICK2;
AP:=BARSLAST(REF(CROSS(仙人,AAA),1));
底背离:=REF(CLOSE,AP+1)>CLOSE AND 仙人>REF(仙人,AP+1) AND CROSS(仙人,AAA);
STICKLINE(底背离,0,0.1,3,0),COLORMAGENTA;DRAWTEXT(底背离,主筹估算*1.03,'仙底背'),COLORRED;
{DRAWLINE(AP=0,AAA,底背离,AAA,0),COLORRED,LINETHICK4;}
A2P:=BARSLAST(REF(CROSS(AAA,仙人),1));
顶背离:=REF(CLOSE,A2P+1)<CLOSE AND REF(仙人,A2P+1)>仙人 AND CROSS(AAA,仙人);DRAWTEXT(顶背离,主筹估算*1.06,'仙顶');
{}
机构持仓:=STICKLINE(MA(C,20)>=REF(MA(C,20),1),REF(MA(C,20),4),MA(C,20),5,0),COLORLIRED;
JL01:=MA(C,3);
LJL07:=(3*C+L+O+H)/6;
牛线:=(20*LJL07+19*REF(LJL07,1)+18*REF(LJL07,2)+17*REF(LJL07,3)+16*REF(LJL07,4)+15*REF(LJL07,5)+14*REF(LJL07,6)+13*REF(LJL07,7)+12*REF(LJL07,8)+11*REF(LJL07,9)+10*REF(LJL07,10)+9*REF(LJL07,11)+8*REF(LJL07,12)+7*REF(LJL07,13)+6*REF(LJL07,14)+5*REF(LJL07,15)+4*REF(LJL07,16)+3*REF(LJL07,17)+2*REF(LJL07,18)+REF(LJL07,20))/210;
马线:=MA(牛线,5);
等待:=JL01<=牛线;
VAR1L:=(C>REF(C,1) AND C>REF(C,2));
VAR2L:=(REF(VAR1L,1) AND C<=REF(C,1) AND C>=REF(C,2));
VAR3L:=(REF(VAR2L,1) AND C>=REF(C,1) AND C<=REF(C,2));
VAR4L:=(REF(VAR3L,1) AND C<=REF(C,1) AND C>=REF(C,2));
VAR5L:=(REF(VAR4L,1) AND C>=REF(C,1) AND C<=REF(C,2));
VAR6L:=(REF(VAR5L,1) AND C<=REF(C,1) AND C>=REF(C,2));
VAR7L:=(REF(VAR6L,1) AND C>=REF(C,1) AND C<=REF(C,2));
VAR8L:=(REF(VAR7L,1) AND C<=REF(C,1) AND C>=REF(C,2));
VAR9L:=(REF(VAR8L,1) AND C>=REF(C,1) AND C<=REF(C,2));
VARAL:=(REF(VAR9L,1) AND C<=REF(C,1) AND C>=REF(C,2));
VARBL:=(REF(VARAL,1) AND C>=REF(C,1) AND C<=REF(C,2));
VARCL:=(REF(VARBL,1) AND C<=REF(C,1) AND C>=REF(C,2));
机构持仓区域:=MA(C,20)>=REF(MA(C,20),1),NODRAW,COLORLIRED;
持:=VAR1L OR VAR2L OR VAR3L OR VAR4L OR VAR5L OR VAR6L OR VAR7L OR VAR8L OR VAR9L OR VARAL OR VARBL OR VARCL;
DRAWICON(CROSS(AA-0.5,中线) AND AA-0.5<0 AND MA(C,20)>=REF(MA(C,20),1) AND 持 ,AB,25);
DRAWTEXT(仙人>=REF(仙人,1) AND REF(仙人,1)<=REF(仙人,2) AND MA(C,20)>=REF(MA(C,20),1) AND 持,主筹估算,'仙人'),COLORYELLOW;
{DRAWICON(CROSS(主筹估算,散筹估算) AND MA(C,20)>=REF(MA(C,20),1) AND 持,散筹估算,17);}
DRAWICON(CROSS(主筹估算,筹码锁定) {AND MA(C,20)>=REF(MA(C,20),1)} AND 持,主筹估算-0.2,30);
{DRAWICON(超卖11 AND 超卖22,生命量能*2.4,6);}{卖:100,COLORYELLOW;}
DRAWICON(CROSS(主筹估算,散筹估算) AND 生命量能<AA2*0.8 AND 生命量能>=40 AND MA(C,20)>=REF(MA(C,20),1) AND AA2>=REF(AA2,1),80,17);
DRAWICON((涨 OR 强) AND 生命量能<AA2*0.8 AND 生命量能>=40 AND MA(C,20)>=REF(MA(C,20),1) AND AA2>=REF(AA2,1) ,120,5);
DRAWICON(生命量能<AA2*0.8 AND 生命量能>=40 AND MA(C,20)>=REF(MA(C,20),1) AND AA2>=REF(AA2,1),生命量能*0.8,15);
DRAWICON(CROSS(AA2,超强),60,17) ;

通达信仙人筹码标公式

 

相关文章