在线检测未来函数

通达信海底云天指标公式

来源:Internet,编辑:股旁网,2013-04-12

N:=5;
VAR1:=4*SMA((CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100,5,1)-
3*SMA(SMA((CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100,5,1),3.2,1),COLORYELLOW,LINETHICK0;
VAR2:=8,COLORGREEN,LINETHICK0;
买入:IF(CROSS(VAR1,VAR2),50,0),STICK,COLOR0000CC,LINETHICK3;
DRAWTEXT(CROSS(VAR1,VAR2),50,'买入'),COLOR00FFFF;
VARO5:=LLV(LOW,27);
VARO6:=HHV(HIGH,34);
VARO7:=EMA((CLOSE-VARO5)/(VARO6-VARO5)*4,4)*25;
{底部选股}
VAR15:=((HHV(H,21)-C)/(HHV(H,21)-LLV(L,21)))*100-10;
VAR25:=((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100;
VAR35:=SMA(VAR25,13,8);
VAR45:=SMA(VAR15,21,8);
X2:=CEILING(SMA(VAR35,13,8));
X1:=X2-VAR45 ;
底部选股:IF(X2-VAR45<(-80),85,0),COLORCYAN;
顶点:IF((VARO7<10),90,100) ,COLOR00CCFF,LINETHICK1;
0,LINETHICK2 ,COLORFFCC00;
RSV:=(CLOSE-LLV(LOW,30))/(HHV(HIGH,30)-LLV(LOW,30))*100;
K:=SMA(RSV,5,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
AA3:=(HHV(HIGH,21)-CLOSE)/(HHV(HIGH,21)-LLV(LOW,21))*100-10;
AA4:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
AA5:=SMA(AA4,13,8);
趋势:CEILING(SMA(AA5,13,8)),COLORMAGENTA,LINETHICK2;
IF(趋势>=REF(趋势,1),趋势,DRAWNULL),COLORRED,LINETHICK2;
IF(趋势<REF(趋势,1),趋势,DRAWNULL),COLORGREEN,LINETHICK2;
AA6:=SMA(AA3,21,8);
买观注: STICKLINE(趋势-AA6<-65,0,3,15,1);
DRAWICON(FILTER(J>REF(J,1)AND 趋势>=REF(趋势,1)AND 趋势<25 ,5),趋势,1);
卖观注: STICKLINE(趋势-AA6>85,98,95,15,1),COLORFFFF00;
DRAWICON(FILTER(J<REF(J,1)AND 趋势<=REF(趋势,1)AND J>85 ,5),J,2);
AA:=LLV(LOW,36);
BB:=HHV(HIGH,30);
DD:=(EMA(((CLOSE-AA)/(BB-AA))*(4),4))*(25);
股神:=DD,COLORWHITE,LINETHICK1;
股海:=(((DD-LLV(DD,21))/(HHV(DD,21)-LLV(DD,21)))*(4))*(25);
跟踪:=10,COLOR0000FF;
底部:IF((COUNT((股神>REF(股神,1)),1)=1) AND (REF(股神,1)<REF(REF(股神,1),1)) AND (股神<跟踪),60,0),COLORF00FF0;

通达信海底云天指标公式

 

相关文章