在线检测未来函数

通达信上下限主图指标公式

来源:Internet,编辑:股旁网,2013-04-14

HH:=HHV(H,200);
LL:=LLV(L,200);
上涨:BARSSINCE(BACKSET(ISLASTBAR,BARSLAST(L=LL)+1)),COLOR0000FF,NODRAW;
↑空间%:(C/REF(L,上涨)-1)*100,COLOR00FFFF,NODRAW;
最高%:(HH/REF(L,上涨)-1)*100,COLORFF00FF,NODRAW;
下跌:BARSSINCE(BACKSET(ISLASTBAR,BARSLAST(H=HH)+1)),COLOR00FF00,NODRAW;
↓空间%:(C/REF(H,下跌)-1)*100,COLOR888899,NODRAW;
最低%:(LL/REF(H,下跌)-1)*100,COLORFF0000,NODRAW;
天线:REFDATE(REF(H,下跌),DATE),POINTDOT,LINETHICK3,COLORYELLOW;
地线:REFDATE(REF(L,上涨),DATE),POINTDOT,LINETHICK3,COLOR00FF00;
中线:REFDATE((天线-地线)*0.5+地线,DATE),POINTDOT,LINETHICK3,COLOR00FF00;
STICKLINE(上涨=0,天线,地线,0,-1),COLORYELLOW;
STICKLINE(下跌=0,天线,地线,0,-1),COLORGREEN;
DRAWTEXT(下跌=0,地线*1.01,'-最低'),COLOR00FF00;
DRAWTEXT(上涨=0,天线*0.99,'-最高'),COLOR0000FF;
{2}
高:=天线;
低:=地线;
H1:=高-(高-低)*0.191;
H2:=高-(高-低)*0.382;
H3:=高-(高-低)*0.5;
H4:=高-(高-低)*0.618;
H5:=高-(高-低)*0.809;
DRAWTEXT(下跌=0,高,'高'),COLORGREEN;
DRAWTEXT(下跌=0,H1,'809'),COLORCYAN;
DRAWTEXT(下跌=0,H2,'618'),COLORGRAY;
DRAWTEXT(下跌=0,H3,'中'),COLORYELLOW;
DRAWTEXT(下跌=0,H4,'382'),COLORLIRED;
DRAWTEXT(下跌=0,H5,'191'),COLORMAGENTA;
DRAWTEXT(上涨=0,H1,'风险'),COLORCYAN;
DRAWTEXT(上涨=0,H2,'高位'),COLORGRAY;
DRAWTEXT(上涨=0,H3,'中'),COLORYELLOW;
DRAWTEXT(上涨=0,H4,'低吸'),COLORLIRED;
DRAWTEXT(上涨=0 ,H5,'盘整'),COLORMAGENTA;
DRAWTEXT(上涨=0,低,'低'),COLORRED;
DRAWTEXT(上涨=5,H*1.02,'5'),COLOR00FFFF;
DRAWTEXT(上涨=8,H*1.02,'8'),COLOR00FFFF;
DRAWTEXT(上涨=13,H*1.02,'13'),COLOR00FFFF;
DRAWTEXT(上涨=21,H*1.02,'21'),COLOR00FFFF;
DRAWTEXT(上涨=34,H*1.02,'34'),COLOR00FFFF;
DRAWTEXT(上涨=55,H*1.02,'55'),COLOR00FFFF;
DRAWTEXT(上涨=89,H*1.02,'89'),COLOR00FFFF;
DRAWTEXT(上涨=144,H*1.02,'144'),COLOR00FFFF;
DRAWTEXT(上涨=180,H*1.02,'180'),COLOR00FFFF;
DRAWTEXT(上涨=250,H*1.02,'250'),COLOR00FFFF;
DRAWTEXT(下跌=5,L*0.98,'-5'),COLOR00FF00;
DRAWTEXT(下跌=8,L*0.98,'-8'),COLOR00FF00;
DRAWTEXT(下跌=13,L*0.98,'-13'),COLOR00FF00;
DRAWTEXT(下跌=21,L*0.98,'-21'),COLOR00FF00;
DRAWTEXT(下跌=34,L*0.98,'-34'),COLOR00FF00;
DRAWTEXT(下跌=55,L*0.98,'-55'),COLOR00FF00;
DRAWTEXT(下跌=89,L*0.98,'-89'),COLOR00FF00;
DRAWTEXT(下跌=144,L*0.98,'-144'),COLOR00FF00;
DRAWTEXT(下跌=180,L*0.98,'-180'),COLOR00FF00;
DRAWTEXT(下跌=250,L*0.98,'-250'),COLOR00FF00;
{3}
C2:=REF(C,1);
跌停:=IF((C2-C)*100/C2>=(10-0.01*100/C2),1,0);
涨停:=IF((C-C2)*100/C2>=(10-0.01*100/C2),1,0);
STICKLINE(跌停,C,O,3.3,0),COLORBLUE;
STICKLINE(跌停,H,L,0,0),COLORBLUE;
STICKLINE(涨停,C,O,3.3,0),COLOR0077FF;
STICKLINE(涨停,C,O,2.8,0),COLOR0099FF;
STICKLINE(涨停,H,L,0,0),COLOR00FFFF;

通达信上下限主图指标公式

 

相关文章