在线检测未来函数

通达信黑马通道主图指标公式

来源:Internet,编辑:股旁网,2013-04-14

VAR1:=(C+H+O+L)/4;
AQWE:=XMA(VAR1,20)*(1+80/1000);
SQWE:=XMA(VAR1,32)*(1-100/1000);
AA1:=AQWE;
BB1:=SQWE;
通道上轨:AA1,COLORYELLOW,LINETHICK2;
通道下轨:BB1,COLORRED,LINETHICK2;
风险:=100*(L-BB1)/BB1,NODRAW;
幅度:=100*(AA1-BB1)/BB1,NODRAW;
STICKLINE(AA1>LOW AND AA1<HIGH,AA1,MAX(AA1,MAX(OPEN,CLOSE)),2,0),COLORYELLOW;
STICKLINE(AA1>LOW AND AA1<HIGH,AA1,HIGH,0,0),COLORYELLOW;
STICKLINE(AA1<LOW,OPEN,CLOSE,3,0),COLORYELLOW;
STICKLINE(AA1<LOW,OPEN,CLOSE,1,0),COLORYELLOW;
STICKLINE(AA1<LOW,HIGH,LOW,0,0),COLORYELLOW;
STICKLINE(BB1>LOW AND BB1<HIGH,BB1,MIN(MIN(OPEN,CLOSE),BB1),2,0),COLORRED;
STICKLINE(BB1>MIN(C,O) AND BB1<MAX(C,O),BB1,MIN(OPEN,CLOSE),2,0),COLORRED;
STICKLINE(BB1>HIGH,OPEN,CLOSE,2,0),COLORRED;
STICKLINE(BB1>HIGH,HIGH,LOW,0,0),COLORRED;
VAR2:=LLV(LOW,10);
VAR3:=HHV(HIGH,25);
动能趋势线:=100*EMA((CLOSE-VAR2)/(VAR3-VAR2),4);
DRAWTEXT(CROSS(动能趋势线,70)AND C>通道上轨,HIGH*1.02,'↖卖'),COLORYELLOW;
RSV:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
X:=LLV(J,2)=LLV(J,8);
DRAWTEXT(CROSS(J,REF(J+0.01,1)) AND X AND J<20 AND C<通道下轨,LOW,'↖买'),COLORRED;

通达信黑马通道主图指标公式

 

相关文章