在线检测未来函数

通达信五步操作指标公式

来源:Internet,编辑:股旁网,2013-04-15

v1:=(100-WINNER(h)*100)/2.5;
v2:=WINNER(l)*100/2.5;
多头快速:=ema(v2,3),COLORRED;
v3:=BARSLAST(CROSS(多头快速,18))-if(BARSLAST(CROSS(18,多头快速))<=BARSLAST(CROSS(多头快速,18)),BARSLAST(CROSS(18,多头快速)),0);
v4:=BARSLAST(CROSS(多头快速,27))-if(BARSLAST(CROSS(27,多头快速))<=BARSLAST(CROSS(多头快速,27)),BARSLAST(CROSS(27,多头快速)),0);
v5:=BARSLAST(CROSS(多头快速,36))-if(BARSLAST(CROSS(36,多头快速))<=BARSLAST(CROSS(多头快速,36)),BARSLAST(CROSS(36,多头快速)),0);
小牛出头:if(v3>0 and 多头快速>=18,v3,0),COLORMAGENTA,LINETHICK0;
黄马挂:if(v4>0 and 多头快速>=27,v4,0),COLORYELLOW,LINETHICK0;
红顶子:if(v5>0 and 多头快速>=36,v5,0),COLORRED,LINETHICK0;
STICKLINE(v3=1 and 多头快速>=18,0,1,6,0),COLORMAGENTA;
STICKLINE(v3=2 and 多头快速>=18,0,2,6,0),COLORMAGENTA;
STICKLINE(v3=3 and 多头快速>=18,0,3,6,0),COLORMAGENTA;
STICKLINE(v3=4 and 多头快速>=18,0,4,6,0),COLORMAGENTA;
STICKLINE(v3>=5 and 多头快速>=18,0,5,6,0),COLORMAGENTA;
STICKLINE(v4>=1 and 多头快速>=27,if(v3<=5,v3,5),9,6,0),COLORYELLOW;
STICKLINE(v5>0 and 多头快速>=36,9,10,6,0),COLORRED;

通达信五步操作指标公式

 

相关文章