在线检测未来函数

通达信漂亮公主指标公式

来源:Internet,编辑:股旁网,2013-04-15

80,COLORRED;
20;
VAR1:=HHV(HIGH,9)-LLV(LOW,9);
VAR2:=HHV(HIGH,9)-C;
VAR3:=C-LLV(LOW,9);
VAR4:=VAR2/VAR1*100-70;
VAR5:=(C-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;
VAR6:=(2*C+H+L)/4;
VAR7:=SMA(VAR3/VAR1*100,3,1);
VAR8:=LLV(LOW,34);
VAR9:=SMA(VAR7 ,3 ,1 )-SMA(VAR4 ,9 ,1);
VAR10:=IF(VAR9>100 ,VAR9-100 ,0 );
VAR11:=HHV(HIGH,34);
VAR12:=EMA((VAR6- VAR8)/(VAR11-VAR8)*100,13 );
VAR13:=EMA(0.667*REF(VAR12 ,1) +0.333*VAR12,2 );
VAR13,COLORRED;
STICKLINE(VAR12-VAR13 >0,VAR12 ,VAR13 ,8 ,0 ),COLOR00FF0F;
STICKLINE(VAR12-VAR13 <0,VAR12 ,VAR13 ,8 ,0),COLORRED;
差值:(VAR12-VAR13)*5,POINTDOT,COLOR33CC00;
STICKLINE( 差值>=0 ,0 ,差值 ,4 ,0 ),COLORYELLOW;
STICKLINE( 差值>=0 ,0 ,差值*0.8 ,4 ,0),COLORFFAA66;
STICKLINE( 差值>=0 ,0 ,差值*0.6 ,4 ,0),COLORFFBB99;
STICKLINE( 差值>=0 ,0 ,差值*0.4 ,4 ,0),COLORFFCCCC;
STICKLINE( 差值>=0 ,0 ,差值*0.2 ,4 ,0),COLORFFDDDD;
STICKLINE( 差值<=0 ,0 ,差值*1 ,4 , 0),COLORGREEN;
STICKLINE( 差值<=0 ,0 ,差值*0.8 ,4 ,0),COLOR33CC00;
STICKLINE( 差值<=0 ,0 ,差值*0.6 ,4 ,0),COLOR339900;
STICKLINE( 差值<=0 ,0 ,差值*0.4 ,4 ,0),COLOR337700;
STICKLINE( 差值<=0 ,0 ,差值*0.2 ,4 ,0),COLOR005500;

通达信漂亮公主指标公式

 

相关文章