在线检测未来函数

通达信金K线主图指标公式

来源:Internet,编辑:股旁网,2013-04-19

综价:=(3*C+O)/4;
综价均3:=WMA(综价,3);
短升:=综价均3>REF(综价均3,1);
金操盘线:IF(短升,综价均3*0.95,综价均3*1.05),COLOR006600;
IF(短升,金操盘线,DRAWNULL),COLOR008888,LINETHICK3;
IF(短升,金操盘线,DRAWNULL),COLORYELLOW;
STICKLINE(短升,H,L,0,0),COLORYELLOW;
STICKLINE(短升,O,C,3,0),COLOR3666EE;
STICKLINE(短升,O,C,3,0),COLOR2299EE;
STICKLINE(短升,O,C,3,0),COLOR11AAEF;
STICKLINE(短升,O,C,3,0),COLOR00BBFE;
STICKLINE(短升,O,C,3,0),COLOR00CCFE;
STICKLINE(短升,O,C,3,0),COLOR00DDFF;
STICKLINE(短升,O,C,2,0),COLOR00EEFF;
STICKLINE(短升,O,C,1,0),COLOR00FFFF;
STICKLINE(NOT(短升),H,L,0,0),COLOR006600;
STICKLINE(NOT(短升),O,C,3,0),COLOR006600;
买入:短升 AND COUNT(短升,2)=1,COLOR0000FF,LINETHICK0;
DRAWICON(买入,L,1);
HGY:=17;
转强信号:=FILTER(COUNT((100*(EMA(EMA(EMA(C,HGY),HGY),HGY)-
REF(EMA(EMA(EMA(C,HGY),HGY),HGY),1))/REF(EMA(EMA(EMA(C,HGY),HGY),
HGY),1))<REF((100*(EMA(EMA(EMA(C,HGY),HGY),HGY)-REF(EMA(EMA(EMA(C,
HGY),HGY),HGY),1))/REF(EMA(EMA(EMA(C,HGY),HGY),HGY),1)),1),5)>=4
AND ((WINNER(C*0.95)>0.5 AND COST(85)<C AND (100*(EMA(EMA(EMA(C,HGY),
HGY),HGY)-REF(EMA(EMA(EMA(C,HGY),HGY),HGY),1))/REF(EMA(EMA(EMA(C,HGY),
HGY),HGY),1))>0) OR ((100*(EMA(EMA(EMA(C,HGY),HGY),HGY)-REF(EMA(EMA
(EMA(C,HGY),HGY),HGY),1))/REF(EMA(EMA(EMA(C,HGY),HGY),HGY),1))>
REF((100*(EMA(EMA(EMA(C,HGY),HGY),HGY)-REF(EMA(EMA(EMA(C,HGY),HGY),
HGY),1))/REF(EMA(EMA(EMA(C,HGY),HGY),HGY),1)),1) AND (100*(EMA(EMA(
EMA(C,HGY),HGY),HGY)-REF(EMA(EMA(EMA(C,HGY),HGY),HGY),1))/
REF(EMA(EMA(EMA(C,HGY),HGY),HGY),1))>0) OR ((100*(EMA(EMA(EMA(C,HGY),
HGY),HGY)-REF(EMA(EMA(EMA(C,HGY),HGY),HGY),1))/REF(EMA(EMA(EMA(C,HGY),
HGY),HGY),1))<=0 AND (100*(EMA(EMA(EMA(C,HGY),HGY),HGY)-REF(EMA(EMA(
EMA(C,HGY),HGY),HGY),1))/REF(EMA(EMA(EMA(C,HGY),HGY),HGY),1))>REF((
100*(EMA(EMA(EMA(C,HGY),HGY),HGY)-REF(EMA(EMA(EMA(C,HGY),HGY),HGY),
1))/REF(EMA(EMA(EMA(C,HGY),HGY),HGY),1)),1))),5),COLOR00FFFF;
STICKLINE(转强信号,L*0.99,L*0.97,3,0),LINETHICK1,COLORRED;
STICKLINE(转强信号,L*0.99,L*0.97,1,0),LINETHICK1,COLORYELLOW;
DRAWTEXT(转强信号,L*0.95,'转强信号')COLORYELLOW;
止损:=REF(HHV(H,13),1)*0.95,COLORGRAY,DOTLINE;
STICKLINE(CURRBARSCOUNT=1,止损,止损,80,-1),COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=1,止损*0.995,'盘中破坚决止损★'),COLORGREEN;
买卖:(EMA(C,3.14)+EMA(C,6.28))/2,COLORRED,NODRAW;
吸:买卖*0.935,COLORWHITE,NODRAW;
抛:买卖*1.075,COLORYELLOW,NODRAW;
DRAWTEXT(L<买卖*0.935,L*0.98,'吸1/5')COLORWHITE;
DRAWTEXT(L<买卖*0.935,L*0.95,'反弹出')COLORYELLOW;
DRAWTEXT(H>买卖*1.075 AND C/REF(C,1)<1.091,H*1.04,'抛一半')COLORWHITE;
DRAWTEXT(H>买卖*1.075 AND C/REF(C,1)<1.091,H*1.01,'再低吸')COLORYELLOW;

通达信金K线主图指标公式

 

相关文章