在线检测未来函数

通达信超越MACD指标公式

来源:Internet,编辑:股旁网,2013-04-18

DIFF:EMA(CLOSE,8)-EMA(CLOSE,26);
DEA:EMA(DIFF,9);
MACD:2*(DIFF-DEA), COLORSTICK,LINETHICK2;
DRAWTEXT(CROSS(DIFF,DEA),DIFF,'☆'),COLORRED;
{DRAWICON(CROSS(DIF,DEA),DIF*1.05,1);
DRAWICON(CROSS(DEA,DIF),DEA*0.90,2);}
月DIFF:="MACD.DIF#MONTH"COLOR0080FF;
月DEA:="MACD.DEA#MONTH",COLOR0080FF,LINETHICK2;
周DIFF:="MACD.DIF#WEEK"COLORRED;
周DEA:="MACD.DEA#WEEK",COLORRED,LINETHICK2;
日DIFF:="MACD.DIF",COLORWHITE;
日DEA:="MACD.DEA",COLORWHITE,LINETHICK2;
日金:IF(CROSS(日DIFF,日DEA),0.125,0),COLORYELLOW;
周金:IF(CROSS(周DIFF,周DEA),0.15,0),COLORRED;
月金:IF(CROSS(月DIFF,月DEA),0.175,0),COLORGREEN;
DRAWICON(周金 AND 日金,-0.1,7);
DRAWICON(周金 AND 月金,-0.15,11);
DRAWICON(日金 AND 月金,-0.1,1);
日死:IF(CROSS(日DEA,日DIFF),-0.1,0),COLORYELLOW;
周死:IF(CROSS(周DEA,周DIFF),-0.125,0),COLORRED;
月死:IF(CROSS(月DEA,月DIFF),-0.15,0),COLORGREEN;
DRAWICON(周死 AND 日死,-0.1,8);
DRAWICON(周死 AND 月死,-0.15,12);
DRAWICON(日死 AND 月死,-0.15,2);
低位金叉:=CROSS(DIFF,DEA) AND DIFF<-0.1,NODRAW;
STICKLINE(低位金叉,0,0.08,6,0),COLORYELLOW;
DRAWTEXT(低位金叉,0.16,' 低位金叉'),COLORWHITE;
JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));
二次金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1,NODRAW;
STICKLINE(二次金叉,0,0.06,6,0),COLORFF00FF;
DRAWICON(二次金叉,DEA*0.9,1) ;
DRAWTEXT(二次金叉,0.225,' 二次金叉'),COLORYELLOW;
A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
背离:=REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA),NODRAW;
STICKLINE(底背离,0,0.03,6,0),COLOR00FF00;
底背:DRAWLINE(A1=0,DEA,底背离,DEA,0),COLORRED,NODRAW;
DRAWTEXT(底背离,0.10,' 底背离'),COLORFF00FF;
A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));
顶背离:=REF(CLOSE,A2+1)<CLOSE AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF),NODRAW;
顶背:DRAWLINE(A2=0,DEA,顶背离,DEA,0),COLORGREEN,LINETHICK2;
DRAWTEXT(低位金叉 AND 二次金叉 AND 底背离,0.275,'三全项'),COLOR0000FF,LINETHICK2;
DRAWICON(CROSS(DIFF,DEA),DEA,1);
DRAWICON(CROSS(DEA,DIFF),DEA,2);
WW:=DEA>REF(DEA,1);
DD:=CROSS(DIFF,REF(DIFF,1));
反身向上:IF((WW AND DD),0.25,0),COLORWHITE;
DRAWTEXT(反身向上,0.17,' 反身上'),COLORWHITE;
AD:=LOW=LLV(LOW,14) AND LOW<REF(LOW,1) AND LOW<REF(LOW,5) AND MACD>REF(MACD,1) AND 0>MACD AND 0>REF(MACD,1);
DRAWICON(AD,MACD,9);

通达信超越MACD指标公式

 

相关文章