在线检测未来函数

飞狐北沙矩形主图指标公式

来源:Internet,编辑:股旁网,2013-04-20

INPUT:N(120,0,9999);
TS:=BARSLAST(L=LLV(L,N)); P:=DATACOUNT;
开始信号:=FILTERX(TS=0,BARSSINCE(C));
开始天数:=BARSLAST(开始信号);
天数横线:=开始天数[P];
最后最高:=HHV(H,天数横线);
低点:LINEVALUE(L=LLV(L,N),L,ISLASTBAR,REF(L,TS),0,0),COLOR00CC00;
高点:LINEVALUE(L=LLV(L,N),最后最高[P],ISLASTBAR,REF(最后最高[P],
TS),0,0),COLOR00CCCC;
STICKLINE(开始信号,L,最后最高[P],0,0),COLOR00AA00;
STICKLINE(ISLASTBAR,低点,高点,0,0),COLOR00AA00;
C2:=REF(C,1);
涨停:=REF(C,1)*1.1-C<0.01 AND H=C,LINETHICK;
STICKLINE(涨停,OPEN,CLOSE,2.6666666666666666666666666666667,0),COLORRED;
STICKLINE(涨停,H,L,0,0),COLORRED;
跌停:=IF((C2-C)*100/C2>=(10-0.01*100/C2) AND L=C,1,0),LINETHICK;
STICKLINE(跌停,OPEN,CLOSE,2.6666666666666666666666666666667,0),COLORBLUE;
STICKLINE(跌停,H,L,0,1),COLORBLUE;
CC:=C;
差:=(高点-低点)/天数横线;
收盘差:=CC[P]-低点;
对角差:=高点-低点;
对角角度:ATAN((对角差/(对角差*((天数横线-1)/天数横线))-1)*100)*57.3,COLORFFFF00,LINETHICK,PRECISION2;
差60度:=(高点-低点)*60/对角角度;
差45度:=(高点-低点)*45/对角角度;
差55度:=(高点-低点)*55/对角角度;
差50度:=(高点-低点)*50/对角角度;
差65度:=(高点-低点)*65/对角角度;
//角度65:=IF(TS>=0 AND 低点+(差65度/天数横线)*TS<=高点,低点+(差65度/天数横线)*TS,0),COLORC0C000,LINEDOT,LINETHICK,PRECISION2;
//PARTLINE(TS>=0 AND 低点+(差65度/天数横线)*TS<=高点,低点+(差65度/天数横线)*TS),COLORC0C000,LINEDOT;
角度50:IF(TS>=0 AND 低点+(差50度/天数横线)*TS<=高点,低点+(差50度/天数横线)*TS,0),COLORC0C000,LINEDOT,LINETHICK,PRECISION2;
PARTLINE(TS>=0 AND 低点+(差50度/天数横线)*TS<=高点,低点+(差50度/天数横线)*TS),COLORC0C000,LINEDOT;
角度55:IF(TS>=0 AND 低点+(差55度/天数横线)*TS<=高点,低点+(差55度/天数横线)*TS,0),COLORC0C000,LINEDOT,LINETHICK,PRECISION2;
PARTLINE(TS>=0 AND 低点+(差55度/天数横线)*TS<=高点,低点+(差55度/天数横线)*TS),COLORC0C000,LINEDOT;
对角线:IF(TS>=0 AND 低点+差*TS<=高点,低点+差*TS,0),COLORYELLOW,LINETHICK,PRECISION2;
PARTLINE(TS>=0 AND 低点+差*TS<=高点,低点+差*TS),COLORYELLOW,LINETHICK2;
角度60:IF(TS>=0 AND 低点+(差60度/天数横线)*TS<=高点,低点+(差60度/天数横线)*TS,0),COLORC0C000,LINEDOT,LINETHICK,PRECISION2;
PARTLINE(TS>=0 AND 低点+(差60度/天数横线)*TS<=高点,低点+(差60度/天数横线)*TS),COLORC0C000,LINEDOT;
角度45:IF(TS>=0 AND 低点+(差45度/天数横线)*TS<=高点,低点+(差45度/天数横线)*TS,0),COLORGREEN,LINETHICK,PRECISION2;
PARTLINE(TS>=0 AND 低点+(差45度/天数横线)*TS<=高点,低点+(差45度/天数横线)*TS),COLORGREEN;
收盘角度:(收盘差*对角角度)/对角差,LINETHICK,PRECISION2;
//收盘线:=IF(TS>=0 AND 低点+(收盘差/天数横线)*TS<=高点,低点+(收盘差/天数横线)*TS,0),COLORFFFFCC,LINETHICK,PRECISION2;
//PARTLINE(TS>=0 AND 低点+(收盘差/天数横线)*TS<=高点,低点+(收盘差/天数横线)*TS),COLORFFFFCC;

飞狐北沙矩形主图指标公式

 

相关文章