在线检测未来函数

通达信ADXCD指标公式

来源:Internet,编辑:股旁网,2013-04-21

使用方法: 看带线的运行情况。 当带线金叉时表示趋势相多头扭转(买入),死叉时表示趋势相空头扭转(卖出)。 当带线运行在0下红线之下,空头绝对主导市场,(持币) 0下红线之上,空头相对主导市场。(持股持币都可) 当带线运行在0上红线之下,多头相对主导市场,(持股持币都可) 0上红线之上,多头绝对主导市场。(持股)

P:=14;
TRR := SUM(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),P);
HD := HIGH-REF(HIGH,1);
LD := REF(LOW,1)-LOW;
DMP:= SUM(IF(HD>0 AND HD>LD,HD,0),P);
DMM:= SUM(IF(LD>0 AND LD>HD,LD,0),P);
PDI:=DMP*100/TRR,COLORGRAY;
MDI:=DMM*100/TRR;
M:=P*0.42;
ADX: MA((PDI-MDI)/(MDI+PDI)*100,M),COLORYELLOW,LINETHICK2;
ADXR:(ADX+REF(ADX,M))/2,COLORGREEN;
30,COLORRED,DOTLINE;
0,COLORCC66CC,LINETHICK2;
(-30),COLORRED,DOTLINE;
DIFF:=ADX-ADXR;
DEA:=EMA(DIFF,9);
ADXCD:2*DIFF-DEA,STICK,COLORGRAY;

通达信ADXCD指标公式

 

相关文章