在线检测未来函数

通达信选潜伏黑马股主图指标公式

来源:Internet,编辑:股旁网,2013-04-21

VAR1:=EMA(C,3);
VAR2:=EMA(C,5);
VAR3:=EMA(C,10);
VAR4:=EMA(C,20);
VAR5:=EMA(C,30);
VAR6:=(VAR2+VAR3+VAR4+VAR5)/4;
VAR7:=(VAR6-REF(VAR6,15))/REF(VAR6,15)*100;
VAR8:=(VAR6-REF(VAR6,15))/REF(VAR6, 15)*100;
VAR9:=EMA(VAR7,8);
STICKLINE(VAR7<1*REF(VAR7,1),H,L,0.5,0),COLORBLUE;
STICKLINE(VAR7<1*REF(VAR7,1),O,C,5, 1),COLORBLUE;
STICKLINE(VAR7>1*REF(VAR7,1),H,L,0.5,0),COLORRED;
STICKLINE(VAR7>1*REF(VAR7,1),O,C,5, 1),COLORRED;
STICKLINE(VAR7<1*REF(VAR7,1) AND VAR9>1*REF(VAR9,1),H,L,0.5,0),COLORGREEN;
STICKLINE(VAR7<1*REF(VAR7,1) AND VAR9>1*REF(VAR9,1),O,C,5, 1),COLORGREEN;
买进价:=((C-REF(MA(C,6),1))/6+MA(C,6))*1.004;
买进条件:=CROSS(C,买进价) AND 买进价>REF(买进价,1);
STICKLINE(买进条件,H,L,0.5,1),COLORWHITE,LINETHICK1;
STICKLINE(买进条件,O,C,6,0),COLORWHITE,LINETHICK1;
加码价:=((C-REF(MA(C,18),1))/18+MA(C,18))*1.004;
加码条件:=CROSS(C,加码价) AND 加码价>REF(加码价,1);
STICKLINE(加码条件,H,L,0.5,1),COLORYELLOW,LINETHICK1;
STICKLINE(加码条件,O,C,6,0),COLORYELLOW,LINETHICK1;
A11:=(H+L+2*C)/4;
B11:=EMA(A11,2);
回归值:FORCAST(B11,9),COLORWHITE,LINETHICK;
IF(A11>回归值,回归值,DRAWNULL),LINETHICK2,COLORRED;
IF(A11<回归值,回归值,DRAWNULL),LINETHICK2,COLORGREEN;
A:=HHV(MA((L+H+C)/3,3),3);
B:=LLV(MA((L+H+C)/3,3),5);
A1:=COST(95);
A2:=COST(5);
LY:=(A1-A2)*100/(A1+A2);
V1:=REF(C,1);
V2:=SMA(MAX(C-V1,0),6,1)/SMA(ABS(C-V1),6,1)*100;
VAR11:=(C+L+H)/3;
VAR21:=EMA(VAR11,6);
VAR31:=EMA(VAR21,5);
VAR41:=EMA(VAR31,12);
VAR51:=EMA(VAR41,5);
生命线:EMA(VAR31,30),COLORRED,POINTDOT;
DRAWICON(C>=生命线,生命线,13);
DRAWICON(C<生命线,生命线,14);
VAR30:=(2*(C+L)/2+(C+H)/2+L)/4*1;
下降通道阻击线:=EMA(VAR30,89)*0.91*1;
VAR50:=IF(VOL>0,1,0);
VAR60:=LOW<=下降通道阻击线;
VAR70:=FILTER(VAR60*VAR50,30)*1;
VAR90:=IF(VOL>0,1,0);
VARA0:=FILTER(VAR6,13)*1;
VARB0:=VAR70 OR VARA0*VAR90;
DRAWTEXT(VARB0*1,LOW,'阻击'),COLORYELLOW ;

通达信选潜伏黑马股主图指标公式

 

相关文章