在线检测未来函数

大智慧威廉顶底指标公式

来源:Internet,编辑:股旁网,2013-04-22

威廉波段:=100-(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34))*100;
威廉风险:=IF(威廉波段>95,95,110);
FILLRGN(110,威廉风险,威廉风险<=110,RGB(0,250,250),RGB(0,0,0));
威廉顶部:威廉风险,COLORFF0000,LINETHICK2;
WLDB:=IF(威廉波段<5,15,-10);
FILLRGN(WLDB,-10,WLDB>=-10,RGB(250,250,0),RGB(0,0,0));
威廉底部:WLDB,COLORFF0000,LINETHICK2;
N:=3;
VAR01:=MA(HHV(HIGH,485),17);
VAR02:=MA(HHV(HIGH,222),17);
VAR03:=MA(HHV(HIGH,96),17);
VAR04:=MA(LLV(LOW,485),17);
VAR05:=MA(LLV(LOW,222),17);
VAR06:=MA(LLV(LOW,96),17);
VAR07:=MA((VAR04*0.96+VAR05*0.96+VAR06*0.96+VAR01*0.558+VAR02*0.558+VAR03*0.558)/6,17);
VAR08:=MA((VAR04*1.25+VAR05*1.23+VAR06*1.2+VAR01*0.55+VAR02*0.55+VAR03*0.65)/6,17);
VAR09:=MA((VAR04*1.3+VAR05*1.3+VAR06*1.3+VAR01*0.68+VAR02*0.68+VAR03*0.68)/6,17);
VAR10:=MA((VAR07*3+VAR08*2+VAR09)/6*1.738,17);
VAR11:=IF(DATE<=1050531,VAR10,VAR10*DAY);
VAR12:=LOW;
VAR13:=REF(LOW,1);
VAR14:=SMA(ABS(VAR12-VAR13),3,1)/SMA(MAX(VAR12-VAR13,0),N,1)*100;
VAR15:=MA(IF(CLOSE*1.35<=VAR11,VAR14*10,VAR14/10),N);
VAR16:=LLV(LOW,30);
VAR17:=HHV(VAR15,30);
VAR18:=1990831;
VAR19:=IF(DATE<=VAR18,MA(IF(LOW<=VAR16,(VAR15+VAR17*2)/2,0),N),100000000);
VAR20:=(HHV(H,9.8)-C)/(HHV(H,9.8)-LLV(L,9.8))*100;
VAR21:=SMA(VAR20,3,1);
VAR22:=SMA(VAR21,3,1);
VAR23:=3*VAR21-2*VAR22;
VAR24:=IF(VAR23>=100,100,IF(VAR23<=0,0,VAR23));
VAR36:=100-((100*((HHV(HIGH,17))-CLOSE))/((HHV(HIGH,17))-(LLV(LOW,17))));
VAR37:=100-(MA(((100*((HHV(HIGH,17))-CLOSE))/((HHV(HIGH,17))-(LLV(LOW,17)))),4));
VAR38:=MA(VAR37,1);
VAR39:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
MC:=IF((VAR24=0),100,110);
FILLRGN(110,MC,MC<=110,RGB(240,240,0),RGB(0,0,0));
卖出:MC,COLORFF00FF,LINETHICK2;
超低:=IF(VAR19>30000 AND VAR19>30000,20,-10);
FILLRGN(超低,-10,超低>=-10,RGB(250,180,0),RGB(0,0,0));
超低A:超低,COLOR0000FF,LINETHICK2;
CD:=IF(VAR39<5,10,-10);
FILLRGN(CD,-10,CD>=-10,RGB(180,0,0),RGB(0,0,0));
抄底:CD,COLOR00FFFF,LINETHICK2;
DB:IF(VAR19>10000 AND VAR19>20000,0,-10);
FILLRGN(DB,-10,DB>=-10,RGB(240,0,250),RGB(0,0,0));
锯齿底部:DB,COLORFFFF00,LINETHICK2;
超短:IF((VAR36<VAR38),VAR38,VAR36),COLORFF00FF,LINETHICK1;
走势:(VAR38),COLORMAGENTA,LINETHICK1;
FILLRGN(超短,走势,超短>=走势,RGB(250,110,0),RGB(0,250,0));
威廉:威廉波段,COLORCCCC00,LINETHICK2;
A:80,DOTLINE,COLORFFFF00;
B:50,DOTLINE,COLORFF0000;
D:20,DOTLINE,COLOR0000FF;

大智慧威廉顶底指标公式

 

相关文章