在线检测未来函数

通达信金牌操作主图指标公式

来源:Internet,编辑:股旁网,2013-04-23

操盘5日:MA(C,5),COLORFFFFFF;
工作13日:MA(C,13),COLORYELLOW;
生命34日:MA(C,34),COLORMAGENTA;
趋势55日:MA(C,55),COLOR00D300;
长趋:=MA(C,99),COLOR00FF99;
牛熊144日:MA(C,144),COLORBLUE;
JJX:=ABS(OPEN+HIGH+LOW+CLOSE)/4;
VL:=REF(LOW,1); VH:=REF(H,1);
VAR1:=SMA(ABS(H-VH),13,1)/SMA(MAX(H-VH,0),13,1)*100;
VAR2:=SMA(ABS(L-VL),13,1)/SMA(MAX(L-VL,0),13,1)*100;
VAR3:=MA(VAR1,13);
VAR4:=MA(VAR2,13);
底:LLV(L,34),DOTLINE,COLOREA6EB4;
顶:HHV(H,34),DOTLINE,COLORFF972F;
VAR7:=EMA(IF(H>=顶,VAR3,0),3);
VAR8:=EMA(IF(L<=底,VAR4,0),3);
VAR9:=(SMA(SMA((((CLOSE - LLV(LOW,54)) / (HHV(HIGH,54) - LLV(LOW,54))) * 100),7,1),5,1));
VAR10:=((SMA(((CLOSE - LLV(LOW,54)) / (HHV(HIGH,54) - LLV(LOW,54)) * 100),7,1)) * 16.18) - (VAR9* 10.9);
VAR11:=FILTER(IF(VAR10<=VAR9 AND VAR8>REF(VAR8,1),VAR8*8,0),55);
VAR21:=LLV(LOW,60);
VAR31:=HHV(HIGH,60);
VAR41:=EMA((CLOSE-VAR21)/(VAR31-VAR21)*100,13);
VAR51:=EMA(0.667*REF(VAR41,1)+0.333*VAR41,21);
VARL2:=FILTER(CROSS(VAR51,VAR41) AND VAR41>84,13);
DRAWTEXT(VAR11,L*0.98,'←变盘'),COLORFFFF00;
STICKLINE(VAR11,H,L,1,1),COLORRED;
STICKLINE(VAR11,OPEN,CLOSE,4.5,0),COLOR000099;
STICKLINE(VAR11,OPEN,CLOSE,3,0),COLOR0000BB;
STICKLINE(VAR11,OPEN,CLOSE,2,0),COLOR0000FF;
DRAWTEXT(VARL2,H*1.04,'←逃跑'),COLORFF972F;
STICKLINE(VARL2,H,L,1,1),COLORYELLOW;
STICKLINE(VARL2,OPEN,CLOSE,4.5,0),COLOR00CCCC;
STICKLINE(VARL2,OPEN,CLOSE,3,0),COLOR33FFCC;
STICKLINE(VARL2,OPEN,CLOSE,2,0),COLOR00FFFF;
DRAWTEXT(L<COST(3) AND C>COST(3) AND COST(3)>REF(COST(3),1),COST(3),'←黑马'),COLORA6E500;
VAR90:=((((HHV((((EMA(DCLOSE,12)-EMA(DCLOSE,26))-(EMA((EMA(DCLOSE,12)-EMA(DCLOSE,26)),9)))*2),4)<0) AND ((((EMA(DCLOSE,12)-EMA(DCLOSE,26))-(EMA((EMA(DCLOSE,12)-EMA(DCLOSE,26)),9)))*2)>REF((((EMA(DCLOSE,12)-EMA(DCLOSE,26))-(EMA((EMA(DCLOSE,12)-EMA(DCLOSE,26)),9)))*2),1))) AND (REF((((EMA(DCLOSE,12)-EMA(DCLOSE,26))-(EMA((EMA(DCLOSE,12)-EMA(DCLOSE,26)),9)))*2),1)<REF((((EMA(DCLOSE,12)-EMA(DCLOSE,26))-(EMA((EMA(DCLOSE,12)-EMA(DCLOSE,26)),9)))*2),2))) AND (REF((((EMA(DCLOSE,12)-EMA(DCLOSE,26))-(EMA((EMA(DCLOSE,12)-EMA(DCLOSE,26)),9)))*2),2)<REF((((EMA(DCLOSE,12)-EMA(DCLOSE,26))-(EMA((EMA(DCLOSE,12)-EMA(DCLOSE,26)),9)))*2),3)));
DRAWTEXT(VAR90,L*0.98,'←短买'),COLOR1880FF;
DRAWTEXT(CROSS(MA(C,3),MA(C,9)) AND C>=REF(C,1)
AND C>O,L*0.98,'←追加'),COLORMAGENTA;
短线:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4,COLORGREEN,LINETHICK2;
长线:=(EMA(C,6)+EMA(C,18)+EMA(C,54)+EMA(C,162))/4,COLOR0000FF,LINETHICK2;
STICKLINE(CROSS(短线,长线),L,L-0.35,1,0),COLORYELLOW;
DRAWTEXT(CROSS(短线,长线),L-0.38,'←走牛') ,COLORYELLOW;
VAR3P:=IF(CLOSE/REF(CLOSE,1)>1.050 AND HIGH/CLOSE<1.010 AND IF(CLOSE>REF(CLOSE,1),88,0)>0, 91, 0);
DRAWTEXT(VAR3P>90,LOW*0.9,'←追涨'),COLORFF00FF;
STICKLINE(VAR3P,L,L*0.92,1.2,0),COLORFF00FF;
SS:=MA((LOW+HIGH+CLOSE)/3,5)>REF(MA((LOW+HIGH+CLOSE)/3,5),1) AND
REF(MA((LOW+HIGH+CLOSE)/3,5),1)<REF(MA((LOW+HIGH+CLOSE)/3,5),2);
SC:=L<HHV(MA((LOW+HIGH+CLOSE)/3,5),13) AND H>HHV(MA((LOW+HIGH+CLOSE)/3,5),13) AND C>REF(C,1) AND C>O;
MR:=SC AND COUNT(SS,2);
买:=MR AND NOT(REF(MR,1)),COLORYELLOW;
STICKLINE(买,L,L*0.96,1.2,0),COLORRED;
DRAWTEXT(买,L*0.93,'←必涨'),COLORRED;
LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
DRAWTEXT(CROSS(84,RSI),H+0.13,'←见好就收'),COLOR00FF00;

通达信金牌操作主图指标公式

 

相关文章