在线检测未来函数

飞狐三明治指标公式

来源:Internet,编辑:股旁网,2013-04-25

BIAS20:=(CLOSE-MA(CLOSE,20))/MA(CLOSE,20)*100;
Q7:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;
持股天数:=BARSLAST((BARSLAST(BIAS20>0 AND REF(BIAS20,1)>0))>0);
利润:IF(持股天数>0,SUM(Q7,持股天数),0),STICK;
持股天数:BARSLAST((BARSLAST(BIAS20>0 AND REF(BIAS20,1)>0))>0),STICK,colorFF00FF;
持币天数:=BARSLAST((BARSLAST(BIAS20<0 AND REF(BIAS20,1)<0))>0),STICK,colorgray;
STICKLINE(利润>0,利润+38,0,5,0),colorFF;
STICKLINE(利润<=0,利润,0,5,0),colorFF00;
STICKLINE(持股天数>0,持股天数+8,0,5,0),colorFF00FF;
//STICKLINE(持币天数>0,持币天数,0,5,0),colorFFFF;
{绝地反击}
VAR1:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100;
VAR2:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VAR3:=(SMA(VAR2,3,1)-18)*1.55;
VAR4:=SMA(VAR3,3,1);
VAR5:=(CLOSE-LLV(LOW,100))/(HHV(HIGH,100)-LLV(LOW,100))*100;
VAR6:=SMA(VAR5,10,1);
VAR7:=(EMA(SMA(VAR6,8,1),34)-25)*2.6;
VAR8:=POW(MA(CLOSE,5),2)+MA(CLOSE,5);
VAR9:=POW(MA(LOW,5),2)+MA(LOW,5);
VARA:=POW(MA(HIGH,5),2)+MA(HIGH,5);
VARB:=((VAR8-LLV(VAR9,64))/(HHV(VARA,64)-LLV(VAR9,64))*150+65-10)/2;
VARC:=SMA(VARB,3,1)*1.5-46;
VARD:=SMA(VARC,3,1);
VARE:=3*VARC-2*VARD;
VARF:=(VAR1+VAR2+VAR5)/3;
VAR10:=((VAR3+VAR3+VAR6+VARC)/4-15)*1.67;
VAR11:=((VAR4+VAR4+VAR7+VARD)/4-15)*1.67;
VAR12:=((VAR1+VAR5*2+VARF+VAR10+VAR11+VARB+VARC+VARD+VARE)/10-15)*1.67;
VAR13:=(HHV(HIGH,5)-CLOSE)/(HHV(HIGH,5)-LLV(LOW,5))*(-1)+0.9;
VAR14:=(HHV(HIGH,10)-CLOSE)/(HHV(HIGH,10)-LLV(LOW,10))*(-1)+0.92;
VAR15:=(HHV(HIGH,15)-CLOSE)/(HHV(HIGH,15)-LLV(LOW,15))*(-1)+0.93;
VAR16:=(HHV(HIGH,55)-CLOSE)/(HHV(HIGH,55)-LLV(LOW,55))*(-1)+0.94;
VAR17:=(HHV(HIGH,89)-CLOSE)/(HHV(HIGH,89)-LLV(LOW,89))*(-1)+0.95;
VAR18:=(HHV(HIGH,120)-CLOSE)/(HHV(HIGH,120)-LLV(LOW,120))*(-1)+0.91;
VAR19:=(HHV(HIGH,180)-CLOSE)/(HHV(HIGH,180)-LLV(LOW,180))*(-1)+0.96;
VAR1A:=((VAR13*8+VAR14*8+VAR15*8+VAR16+VAR17+VAR18+VAR19)/28-0.1)*185;
VAR1B:=SMA(VAR1A,3,1);
VAR1C:=(SMA(VAR1B,8,1)-8)*1.18;
浮动筹码: (VAR10+VAR11+VAR12+VARC+VARD+VARE+VAR1C+VAR7)/13 ;
浮动筹码1: (VAR10+VAR11+VAR12+VARC+VARD+VARE+VAR1C+VAR7)/21 ;
浮动筹码2: (VAR10+VAR11+VAR12+VARC+VARD+VARE+VAR1C+VAR7)/34;
获利筹码: (VAR3+VAR6+VAR1B*2)/4 ;
40;
20;
0;
VARA1:=(CLOSE-LLV(LOW,60.13547854))/(HHV(HIGH,60.13547854)-LLV(LOW,60))*80;
VARB1:=SMA(VARA1,7,1);
VARC1:=SMA(VARB1,5,1);
英雄:IF(CROSS(VARB,VARC) AND VARB<20,100,0),LINETHICK2,COLORRED;
VAR2N:=LLV(LOW,3)<=LLV(LOW,60);
VAR3N:= C>O AND (C/O>1.03 OR C>1.03*REF(C,1));
绝地反击:IF(VAR2N AND VAR3N,90,0),COLORYELLOW,LINETHICK2;
{超级无敌}
Var1:=(CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100;
Var2:=SMA(SMA(Var1,3,1),3,1);
Va3:=EMA(Var2,5);
Var2;
91.307;
6.788;
49.048;
BB:=Va3;
无敌:=3*Var2-2*Va3;
STICKLINE(CROSS(无敌,Var2) AND 无敌<21,Var2-5,Var2+30,8,0);
STICKLINE(CROSS(Var2,无敌) AND 无敌>55,Var2-5,Var2+15,8,0);
DRAWTEXT(CROSS(无敌,Var2) AND 无敌<21,Var2-3,'进'),LINETHICK2,colorwhite;
DRAWTEXT(CROSS(Var2,无敌) AND 无敌>55,Var2+15,'出'),colorgreen;
非常无敌:if(CROSS(无敌,Var2) AND 无敌<21,1,0);

飞狐三明治指标公式

 

相关文章