在线检测未来函数

大智慧KD背离指标公式

来源:Internet,编辑:股旁网,2013-04-26

N:=5;
DRAWGBKLAST(c>0,STRIP(RGB(0,4,10),RGB(0,60,100),0));
RSV:=(CLOSE-LLV(LOW,n))/(HHV(HIGH,n)-LLV(LOW,n))*100;
K:SMA(RSV,5,1),LINETHICK0;
D:SMA(K,3,1),LINETHICK0;
J:=(3*K-2*D);
RSV56:=(CLOSE-LLV(LOW,56))/(HHV(HIGH,56)-LLV(LOW,56))*100;
K1:SMA(RSV56,15,1),LINETHICK0;
D1:SMA(K1,4,1),LINETHICK0;
FILLRGN(K,D,K<D),Color77cc88;
FILLRGN(K,D,K>D),COLOR8888cc;
FILLRGN(K1,D1,K1<D1),COLOR44ff44;
FILLRGN(K1,D1,K1>D1),COLOR4444ff;
买不亏:4*K1-3.1*D1,color592cdb;
反弹:(CROSS(买不亏,12) and llv(买不亏,10)<8)*100,STICK,LINETHICK3,color99ffff;
牛股:(CROSS(K1,d1) and REF(K1,1)<12)*100,STICK,LINETHICK2,colorred;
B1:=BARSLAST(REF(CROSS(K,D),1));
短买:REF(C,B1+1)>C AND K>REF(K,B1+1) AND CROSS(K,D) AND REF(D,B1+1)<20 AND HHV(D,B1+1)<50,LINETHICK0;
VERTLINE(短买,2),COLOR592cdb,pointdot;
A2:=BARSLAST(REF(CROSS(d1,k1),1));
B2:=BARSLAST(REF( CROSS(D,K),1));
S短出:REF(c,B2+1)<c AND K<REF(K,B2+1) AND CROSS(D,K) AND REF(D,B2+1)>80 AND HHV(D,B2+1)>50,LINETHICK0;
S离场:(REF(CLOSE,A2+1)<CLOSE AND d1<REF(d1,A2+1) AND CROSS(d1,k1) AND D1>80) or (CROSS(d1,k1) and (REF(K1,1)>90 or REF(K1,2)>90) ) ,LINETHICK0;
STICKLINE(S离场,100,60,3,0),COLORblue,align0;
STICKLINE(S短出,100,60,3,0),COLORgreen,align0;
F:=IF(C>O,O,C);
火箭升空:(F-l)/l>0.02 and REF(买不亏,1)<12 AND J> REF(J,1) AND IF(C<O,2*(H-F)/F<(F-L)/L,(H-F)/F<(F-L)/L) AND L=LLV(L,7),LINETHICK0;
STICKLINE(火箭升空,0,40,3,0),COLORyellow,align0;
8,pointdot,COLORFFFFFF;
20,pointdot,COLORffdd00;
60,pointdot,COLORFFFFFF;
80,pointdot,COLORFFFFFF;

大智慧KD背离指标公式

 

相关文章