在线检测未来函数

通达信涨停天机副图指标公式

来源:Internet,编辑:股旁网,2013-04-26

量比:=2;
换手:=1;
低价:=1;
高价:=1000;
股本:=1000;
离线:=20;
深度:=50;
上涨:=30;
SHORT:=12;
LONG:=26;
MID:=9;
DIF:=EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);
DEA:=EMA(DIF,MID);
MACD:=(DIF-DEA)*2;
N:=9;
M1:=3;
M2:=3;
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:=SMA(RSV,M1,1);
D:=SMA(K,M2,1);
J:=3*K-2*D;
换手率:=VOL/CAPITAL*100;
A:=(3*C+L+O+H)/6;
X:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+
14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)
+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+
REF(A,20))/210;
中线:=EMA(X,13);
AAA:=(3*C+L+O+H)/6;
C2:=EMA(AAA,6);
C3:=EMA(AAA,5);
短线:=EMA(CLOSE,17);
上涨天数:BARSLAST(短线<中线);
N1:=5;
N4:=34;
CQ:=100*(C-LLV(L,N4))/(HHV(C,N4)-LLV(L,N4));
SAT:=(AMOUNT/C)/(HHV(AMOUNT,N4)/HHV(C,N4));
饱和度:=IF(SAT>1,1,SAT)*100;
W1:=C=HHV(C,20);
W2:=BARSLAST(W1);
W3:=IF(W2>0,REF(C,W2),REF(C,W2));
W4:=CROSS(C,REF(W3,1));
突破:=W4 AND COUNT(W4,5)=1;
峰顶:=饱和度>=97 AND CQ>90;
短期:=100*(C-LLV(L,N1))/(HHV(C,N1)-LLV(L,N1));
KAAAA:=EXIST(CROSS(C2,C3),2);
KAAA:=MA(VOL,10)>MA(VOL,5);
KBBB:=EVERY(C>中线 AND O>中线,5);
KCCC:=HHV(VOL,20)/VOL>量比;
KDDD:=上涨天数<上涨;
KEEE:=SUM(换手率,20)>换手;
KFFF:=C>低价 AND C<高价;
KGGG:=FINANCE(7)/1000000<股本;
KHHH:=EXIST(峰顶,20) OR EXIST(突破,20);
KJJJ:=C/中线<1+0.01*离线;
KIII:=短期<深度;
游资资金:IF(KAAAA AND KBBB AND KCCC AND KDDD AND KEEE AND KFFF AND KHHH,100,0),COLORYELLOW,LINETHICK2;
机构资金:IF(KAAA AND KBBB AND KCCC AND KDDD AND KEEE AND KFFF AND KHHH AND KJJJ AND KIII,70,0),COLORRED,LINETHICK2;
STICKLINE(游资资金,0,30,5,0),COLORYELLOW;
STICKLINE(机构资金,0,20,5,0),COLORRED;

通达信涨停天机副图指标公式

 

相关文章