在线检测未来函数

通达信CCI4系统指标公式

来源:Internet,编辑:股旁网,2013-04-28

B1:=(H + L + C - MA(H,4) - MA(L,4) - MA(C,4) ) * 800 / 3 / (ABS(H + L + C - MA(H,4) - MA(L,4) - MA(C,4) ) + ABS(REF(H,1 ) + REF(L,1 ) + REF(C,1 ) - MA(H,4 ) - MA(L,4 ) - MA(C,4) ) + ABS(REF(H,2) + REF(L,2) + REF(C,2) - MA(H,4) - MA(L,4) - MA(C,4) ) + ABS(REF(H,3 ) + REF(L,3 ) + REF(C,3 ) - MA(H,4 ) - MA(L,4 ) - MA(C,4) ) + 0.000001);
B2:=(REF(H,2) + REF(L,2 ) + REF(C,2 ) - MA(H,4.2 ) - MA(L,4.2) - MA(C,4.2) ) * 800 / 3 / (ABS(REF(H,2) + REF(L,2 ) + REF(C,2 ) - MA(H,4.2 ) - MA(L,4.2) - MA(C,4.2) ) + ABS(REF(H,3 ) + REF(L,3) + REF(C,3 ) - MA(H,4.2) - MA(L,4.2 ) - MA(C,4.2) ) + ABS(REF(H,4) + REF(L,4 ) + REF(C,4 ) - MA(H,4.2) - MA(L,4.2) - MA(C,4.2) ) + ABS(REF(H,5) + REF(L,5) + REF(C,5) - MA(H,4.2) - MA(L,4.2 )- MA(C,4.2)) + 0.000001);
TYP:=(HIGH+LOW+CLOSE)/3;
CCI4A:(TYP-MA(TYP,4))/(0.015*AVEDEV(TYP,4));
CCI4B:(2*B1+3*B2)/2;
-100;

通达信CCI4系统指标公式

 

相关文章