在线检测未来函数

通达信黄金提纯指标公式

来源:Internet,编辑:股旁网,2013-04-28

N:=10;
ZZ:=(HHV(H,3)+LLV(L,3))/2;A:=IF(C>ZZ,VOL,0);B:=IF(C<ZZ,VOL,0);
总0:=(A-B);
BBD:EMA(总0,3)/SUM(VOL,5)*600,LINETHICK;
STICKLINE(BBD>=0,0,BBD,3,0),COLOR000088;
STICKLINE(BBD>=0,0,BBD,1.5,0),COLOR0000AA;
STICKLINE(BBD>=0,0,BBD,1,0),COLOR0000CC;
STICKLINE(BBD>=0,0,BBD,0.5,0),COLOR0000FF;
STICKLINE(BBD<0,0,BBD,3,0),COLOR888800;
STICKLINE(BBD<0,0,BBD,1.5,0),COLORAAAA00;
STICKLINE(BBD<0,0,BBD,1,0),COLORCCCC00;
STICKLINE(BBD<0,0,BBD,0.5,0),COLORFFFF00;
XH1:=REF(BBD,1)<REF(BBD,2) AND REF(BBD,1)<-10 AND BBD>REF(BBD,1) AND BBD>0;
XH2:=REF(BBD,1)>=REF(BBD,2) AND REF(BBD,1)>8 AND BBD<REF(BBD,1) AND BBD<0;
DRAWICON(XH1,-20,1);DRAWICON(XH2,20,2);
AA:=REF(CLOSE,1);
BBB:=SMA(MAX(CLOSE-AA,0),21,1)/SMA(ABS(CLOSE-AA),21,1)*1000;
HHH:=BBB-LLV(BBB,27);
CCC:=LLV(BBB,27)-BBB;
QQ:=(MA(HHH,2)*3+HHH*13)/16,COLORFF00FF,LINETHICK1;
SS:=(MA(CCC,2)*3+CCC*13)/16,COLORFF00FF,LINETHICK1;
GG:=MA(HHH,5),LINETHICK1,COLORGREEN;
MM:=MA(CCC,5),LINETHICK1,COLORGREEN;
WW:=IF(QQ<GG,SS,MM),LINETHICK1,COLOR0000FF;
EE:=IF(SS<MM,GG,QQ),COLORFFFFCC,LINETHICK1;
★买:=IF(EE-WW<5.6,200,0);
RSVV:=(CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10))*100;
VARB2:=(RSVV/2+22)*1;
量:=EMA(VOL,13);
资金:=EMA(AMOUNT,13);
过滤:=((资金 /量) / 100);
提纯:=(((CLOSE -过滤) / 过滤) * 100);
黄金:=((提纯 < (0)) AND ZXNH),COLORRED;
买:IF(黄金 AND RSVV<VARB2-2,180,0),COLOR00FFFF,STICK,LINETHICK1;
DRAWTEXT(买>0,99.6,'买'),COLORFFFFFF;
STICKLINE(买,0,2,0,9),COLOR0000FF;

通达信黄金提纯指标公式

 

相关文章