在线检测未来函数

飞狐解密主力指标公式

来源:Internet,编辑:股旁网,2013-05-02

C0:=(HIGH+LOW+CLOSE)/3;
A1:=HHV(C0,14);
A2:=LLV(C0,14);
A3:=A1-A2;
A4:=EMA((C0-A2)/A3,2)*100;
B1:=HHV(C0,30);
B2:=LLV(C0,30);
B3:=B1-B2;
B4:=EMA((C0-B2)/B3,2)*100;
C1:=HHV(C0,55);
C2:=LLV(C0,55);
C3:=C1-C2;
C4:=EMA((C0-C2)/C3,2)*100;
A1:A4-50,colorFF0000;
A2:B4-50,color99FFCC;
A3:C4-50,colorFF00;
DRAWICON(CROSS(A1,0),0,4);
PARTLINE(A1>45,A1),colorFF;
PARTLINE(A2>45,A2),colorFF;
PARTLINE(A3>45,A3),colorFF;
0,POINTDOT;
50,POINTDOT;
-50,POINTDOT;
BB1:=WINNER(CLOSE)*100;
BB2:=(100-BB1);
BB3:=(ABS(BB1-BB2));
TD:=BACKSET(ISLASTBAR,1);
DRAWTEXT(TD AND BB1,BB1*0.9,'牛'),SHIFT3,colorFF;
DRAWTEXT(TD AND BB2,BB2*0.9,'熊'),SHIFT3,colorFFFF;
DRAWTEXT(TD AND BB3,BB3*0.9,'马'),SHIFT3,colorFF00FF;
STICKLINE(TD,BB1,0,20,0),SHIFT2,colorFF;
STICKLINE(TD,BB2,0,10,0),SHIFT2,colorFFFF;
STICKLINE(TD,BB3,0,5,0),SHIFT2,colorFF00FF;
准备卖:CLOSE/(EMA(EMA((CLOSE+LOW+HIGH)/3,3),18)*1.14)<0.95;
证:准备卖 AND COUNT(准备卖,7)>=1;
DRAWTEXT(证>0 AND REF(证,1)=0,49.9,'准备卖');
卖:CLOSE/(EMA(EMA((CLOSE+LOW+HIGH)/3,3),14)*1.33)<0.95,LINETHICK2,color99FF;
监:卖 AND COUNT(卖,7)>=1;
DRAWTEXT(监>0 AND REF(监,1)=0,0.9,'卖'),PXUP6;
准备买:CLOSE/(EMA(EMA((CLOSE+LOW+HIGH)/3,3),26)*0.9)<0.95,LINETHICK4,colorFF;
会:准备买 AND COUNT(准备买,7)>=1;
DRAWTEXT(会>0 AND REF(会,1)=0,-50,'准备买'),PXUP6,colorFFFF;
HZ3:=SMA(AMOUNT,15,6)-REF(SMA(AMOUNT,15,6),61);
TZ:=LLV(LOW,2);
SMA(DMA(TZ,HZ3),8,4);
SMA(DMA(TZ,HZ3),7,4);
SMA(DMA(TZ,HZ3),6,4);
QQ:=SMA(DMA(TZ,HZ3),5,4);
DRAWTEXT(QQ/REF(QQ,1)<0.97 AND REF(QQ,2)=REF(QQ,13) AND (CLOSE-REF(CLOSE,1))/REF(CLOSE,1)>0.03 ,20,'放心买');
DRAWTEXT((CLOSE-REF(CLOSE,1))/REF(CLOSE,1)>0.08 AND HIGH=CLOSE ,20,'春笋');
放心买:IF(QQ/REF(QQ,1)<0.97 AND REF(QQ,2)=REF(QQ,13) AND (CLOSE-REF(CLOSE,1))/REF(CLOSE,1)>0.03 ,30,0);
春笋:IF((CLOSE-REF(CLOSE,1))/REF(CLOSE,1)>0.08 AND HIGH=CLOSE ,20,0);

飞狐解密主力指标公式

 

相关文章