在线检测未来函数

通达信悍马指标公式

来源:Internet,编辑:股旁网,2013-05-02

在选股时,大家要注意: 1:dif2线一定要上穿或在下线的上面。 2:dif2线有绿变红时且出现红箭头时买入。 3:选股时(即红箭头),参数是1.(选股=1) 4:买入后dif2线有红变绿卖出。

DIF1:=EMA(CLOSE,12)-EMA(CLOSE,26),COLOR00FF00,LINETHICK1;
DEA1:=EMA(DIF1,9),COLOR00FF00,LINETHICK1;
DI:=EMA(CLOSE,4)-EMA(CLOSE,13),COLORMAGENTA,LINETHICK2;
D1:=EMA(DI,5),COLORGRAY;
D2:=EMA(DI,10),COLORGRAY;
D3:=EMA(DI,20),COLORGRAY;
D4:=EMA(DI,30),COLORGRAY;
D5:=EMA(DI,60),COLORGRAY;
D6:=EMA(DI,90),COLORGRAY;
D7:=EMA(DI,120),COLORGRAY;
D8:=EMA(DI,250),COLORGRAY;
AA:=STICKLINE(DI>=REF(DI,1) AND D1>=REF(D1,1) AND D2>=REF(D2,1) AND D3>=REF(D3,1) AND
D4>=REF(D4,1) AND D5>=REF(D5,1) AND D6>=REF(D6,1) AND D7>=REF(D7,1) AND
D8>=REF(D8,1) AND C>EMA(C,11) AND DI>-0.8,DI,0,2,0),COLORRED;
MACD1:=(DIF1-DEA1)*2;
STICKLINE(MACD1>REF(MACD1,1),0,MACD1,2,0),COLOR0000FF;
STICKLINE(MACD1>REF(MACD1,1),0,MACD1,1.8,0),,COLOR0000FF;
STICKLINE(MACD1>REF(MACD1,1),0,MACD1,1.6,0),COLOR0000FF;
STICKLINE(MACD1>REF(MACD1,1),0,MACD1,1.4,0),COLOR0000FF;
STICKLINE(MACD1>REF(MACD1,1),0,MACD1,1.2,0),COLOR0000FF;
STICKLINE(MACD1>REF(MACD1,1),0,MACD1,0.8,0),COLORCC66FF;
STICKLINE(MACD1<REF(MACD1,1),0,MACD1,2,0),COLORFF9900;
STICKLINE(MACD1<REF(MACD1,1),0,MACD1,1.8,0),COLORFF9900;
STICKLINE(MACD1<REF(MACD1,1),0,MACD1,1.6,0),COLORFF9900;
STICKLINE(MACD1<REF(MACD1,1),0,MACD1,1.4,0),COLORFF9900;
STICKLINE(MACD1<REF(MACD1,1),0,MACD1,1.2,0),COLORFF9900;
STICKLINE(MACD1<REF(MACD1,1),0,MACD1,0.8,0),COLORFFCC00;
STICKLINE(MACD1>=0 OR MACD1<=0,0,0,50,1),COLORWHITE;
WY1001:=(2*CLOSE+HIGH+LOW)/4;
WY1002:=EMA(WY1001,4);
WY1003:=EMA(WY1002,4);
WY1004:=EMA(WY1003,4);
X:=(WY1004-REF(WY1004,1))/REF(WY1004,1)*100;
X1:=IF(X<REF(X,1),X,DRAWNULL),COLORWHITE,LINETHICK2;
XO:=MA(X,2),COLOR9932CD;
SI:=REF(X,1);
STICKLINE(X>SI,X,SI,1,0),COLOR0080EF;
STICKLINE(X<SI,X,SI,1,0),COLORFF00CC;
DIF:DIF1,LINETHICK1,COLORGREEN;
DEA:DEA1,LINETHICK1,COLORGREEN;
DIF2:IF(MACD>REF(MACD,1),DIF1,DRAWNULL),COLORRED,LINETHICK1;
DEA2:IF(DEA1<DIF1,DEA1,DRAWNULL),COLORFF00FF,LINETHICK1;
VAR1:=HHV(DEA,41);
VAR2:=LLV(DEA,43);
VAR3:=DEA-(DIF-DEA);
VAR4:=DEA-(DIF-DEA);
SX:IF(DIF>VAR1 AND DEA=VAR1,MAX(LLV(VAR1,10),VAR3),VAR1),COLORCYAN,LINETHICK2;
XX:IF(DIF<VAR2 AND DEA=VAR2,MIN(HHV(VAR2,10),VAR4),VAR2),COLORYELLOW,LINETHICK2;
VARR1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VARR2:=REF(VARR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VARR3:=REF(VARR2,1) AND CLOSE>REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARR4:=REF(VARR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VARR5:=REF(VARR4,1) AND CLOSE>REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARR6:=REF(VARR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VARR7:=REF(VARR6,1) AND CLOSE>REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARR8:=REF(VARR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VARR9:=REF(VARR8,1) AND CLOSE>REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARRA:=REF(VARR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VARRB:=REF(VARRA,1) AND CLOSE>REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARRC:=REF(VARRB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VARRD:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);
VARRE:=REF(VARRD,1) AND CLOSE>REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARRF:=REF(VARRE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VARR10:=REF(VARRF,1) AND CLOSE>REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARR11:=REF(VARR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VARR12:=REF(VARR11,1) AND CLOSE>REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARR13:=REF(VARR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VARR14:=REF(VARR13,1) AND CLOSE>REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARR15:=REF(VARR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VARR16:=REF(VARR15,1) AND CLOSE>REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARR17:=REF(VARR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VARR18:=REF(VARR17,1) AND CLOSE>REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARR19:=REF(VARRD OR VARRE OR VARRF OR VARR10 OR VARR11 OR VARR12 OR VARR13 OR VARR14 OR VARR15 OR VARR16 OR VARR17 OR VARR18,1) AND VARR1;
DRAWICON(VARR19=1,SI-0.08,1);
VARR1A:=REF(VARR1 OR VARR2 OR VARR3 OR VARR4 OR VARR5 OR VARR6 OR VARR7 OR
VARR8 OR VARR9 OR VARRA OR VARRB OR VARRC,1) AND VARRD;
DRAWICON(VARR1A=1,X+0.08,2);
选股:VARR19,COLORRED,NODRAW;

通达信悍马指标公式

 

相关文章