在线检测未来函数

通达信云端优K主图指标公式

来源:Internet,编辑:股旁网,2013-05-04

根据K线变色提示操作,红色操盘线提示持股,绿色谨慎.

黄线1:=EMA((O+C)/2,10),COLORGREEN,LINETHICK2;
黄线2:=EMA((O+C)/2,8.5),POINTDOT,COLORGREEN,LINETHICK3;
黄线3:=EMA((O+C)/2,6),POINTDOT,COLORGREEN,LINETHICK3;
黄线4:=EMA((O+C)/2,4.5),POINTDOT,COLORGREEN,LINETHICK3;
黄线5:EMA((L+H)/2,3),COLORGREEN;
IF(黄线1>=REF(黄线1,0),黄线1,DRAWNULL),COLORRED,LINETHICK2;
IF(黄线1<=REF(黄线1,1),黄线1,DRAWNULL),COLORGREEN,LINETHICK2;
IF(黄线2>=REF(黄线2,1),黄线2,DRAWNULL),POINTDOT,COLORMAGENTA,LINETHICK1;
IF(黄线2<=REF(黄线2,1),黄线2,DRAWNULL),POINTDOT,COLORGREEN,LINETHICK1;
IF(黄线3>=REF(黄线3,1),黄线3,DRAWNULL),POINTDOT,COLORMAGENTA,LINETHICK1;
IF(黄线3<=REF(黄线3,1),黄线3,DRAWNULL),POINTDOT,COLORGREEN,LINETHICK1;
IF(黄线4>=REF(黄线4,1),黄线4,DRAWNULL),POINTDOT,COLORRED,LINETHICK1;
IF(黄线4<=REF(黄线4,1),黄线4,DRAWNULL),POINTDOT,COLORGREEN,LINETHICK1;
IF(黄线5>=REF(黄线5,1),黄线5,DRAWNULL),COLORRED,LINETHICK1;
IF(黄线5<=REF(黄线5,1),黄线5,DRAWNULL),COLORGREEN,LINETHICK1;
强势区:=IF((EVERY(黄线1>=REF(黄线1,1),1)),5,0)COLOR0000FF,LINETHICK3;
买进价:=((C-REF(黄线5,1))/8+黄线5)*1.004;
买进条件:=CROSS(C,买进价) AND 买进价>REF(买进价,1);
白K买进:IF(买进条件,L,H),COLORWHITE,POINTDOT;
STICKLINE(买进条件,H,L,0,1),COLORWHITE,LINETHICK2;
STICKLINE(买进条件,O,C,2,1),COLORWHITE,LINETHICK2;
加码价:=((C-REF(黄线1,1))/20+黄线1)*1.004;
加码条件:=CROSS(C,加码价) AND 加码价>REF(加码价,1);
黄K加仓:IF(加码条件,L,H),COLORYELLOW,POINTDOT;
STICKLINE(加码条件,H,L,0,1),COLORYELLOW,LINETHICK2;
STICKLINE(加码条件,O,C,2,1),COLORYELLOW,LINETHICK2;
KPD1:=EMA(EMA(CLOSE,9),9);
KPD2:=100*WINNER(CLOSE*0.95);
L1:=(EMA(CLOSE,3) - EMA(CLOSE,13));
L2:=EMA(L1,9);
L3:=BARSLAST(CROSS(L1,L2));
L4:=REF(L3,L3+1);
L5:=L2;
ROC:=(CLOSE-REF(CLOSE,21))/REF(CLOSE,21)*100;
AC:=AMOUNT/(VOL);
YY:=MA(AC,13);
LLL:=(C-YY)/YY*100;
MIDC:=MA(CLOSE,22);
UPPERC:=MIDC+2*STD(C,22);
LOWERC:=MIDC-2*STD(C,22);
BBA:=(C-LOWERC)/(UPPERC-LOWERC);
LIFENGCYC:=(REF(LLL,1)<-15 AND REF(BBA,1)<0 AND LLL>REF(LLL,1));
控盘:=(KPD1-REF(KPD1,1))/REF(KPD1,1)*1000;
启动:STICKLINE(IF(CROSS(控盘,0),10,0),O,C,0.5,0),COLOR00FFFF;
拐点:STICKLINE(FILTER(CROSS(ROC,0),6),O,C,0.5,0),COLORFF8080;
变盘:STICKLINE(CROSS(L1,L2) AND L5,O,C,0.5,0),COLOR0080FF;
DRAWTEXT_FIX(1,0.0,0,0,'K线提示:【细K色提示:黄启动 桔黄变盘 紫兰拐点 红买点☆粗K色提示:橙黄买入 紫红顶卖出☆白K买进,黄K加仓】'),COLORMAGENTA;
MID:=(3*CLOSE+LOW+OPEN+HIGH)/6;
VAR111:=EMA(CLOSE,4)-EMA(CLOSE,13);
AA222:=VAR111>=REF(VAR111,1);
BB222:=VAR111<REF(VAR111,1);
买入:DRAWICON(CROSS(AA222,BB222),L*0.994,1);
卖出:DRAWICON(CROSS(BB222,AA222),H*1.004,2);
YTSL:=(3*CLOSE+LOW+OPEN+HIGH)/6;
VAR1:=(CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2));
VAR2:=(REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR3:=(REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR4:=(REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR5:=(REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR6:=(REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR7:=(REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR8:=(REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR9:=(REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARA:=(REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VARB:=(REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARC:=(REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VARD:=(CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2));
VARE:=(REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARF:=(REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR10:=(REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR11:=(REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR12:=(REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR13:=(REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR14:=(REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR15:=(REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR16:=(REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR17:=(REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR18:=(REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR19:=((REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1)) AND VAR1);
VAR1A:=((REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,1)) AND VARD);
短买:=VAR19;
品红离场:=VAR1A;
急速超跌:=(CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*100<-14;
CO:=(C-O);
STICKLINE(急速超跌,O,C-CO/2,2.8,0),COLOR555555;
STICKLINE(急速超跌,O,C-CO/2,2,0),COLOR888888;
STICKLINE(急速超跌,O,C-CO/2,1.5,0),COLORAAAAAA;
STICKLINE(急速超跌,O,C-CO/2,1,0),COLORCCCCCC;
STICKLINE(急速超跌,O,C-CO/2,0.5,0),COLOREEEEEE;
STICKLINE(短买,O,O+CO/3,2,0),COLOR335555;
STICKLINE(短买,O,O+CO/3,2,0),COLOR338888;
STICKLINE(短买,O,O+CO/3,1.5,0),COLOR33AAAA;
STICKLINE(短买,O,O+CO/3,1,0),COLOR33CCCC;
STICKLINE(短买,O,O+CO/3,0,0),COLOR33EEEE;
STICKLINE(品红离场,O,O+CO/3,2,0),COLOR550055;
STICKLINE(品红离场,O,O+CO/3,0.1,0),COLOR880088;
STICKLINE(品红离场,O,O+CO/3,1.5,0),COLORAA00AA;
STICKLINE(品红离场,O,O+CO/3,1,0),COLORCC00CC;
STICKLINE(品红离场,O,O+CO/3,0.5,0),COLOREE00EE;
XXS:=MA(LOW,5)*(1-5/100);
XXS1:=MA(HIGH,5)*(1+5/100);
DRAWTEXT(CROSS(XXS1,C),L*0.98,'*高抛'),COLORYELLOW;
DDDD:=CROSS(C,XXS1);
DRAWTEXT(DDDD,L*0.975,'*明走'),COLORMAGENTA;

通达信云端优K主图指标公式

 

相关文章