在线检测未来函数

通达信红就牛主图指标公式

来源:Internet,编辑:股旁网,2013-05-04

GD:=HHV(HIGH,10);
DD:=LLV(LOW,10);
XJ:=GD*DD;
KF:=SQRT(XJ),COLORGREEN,LINETHICK3;
C1:=C>=KF;
C2:=C<KF;
AA:=C1>=C2 ;
BB:=C2>C1 ;
STICKLINE(AA,C,O,3.2,0),COLORRED;
STICKLINE(AA,H,L,0,0),COLORRED;
STICKLINE(BB,C,O,3.2,0),COLOR00FF00;
STICKLINE(BB,H,L,0,0),COLOR00FF00;
STICKLINE(AA,CLOSE,OPEN,3.2,0),COLOR000099;
STICKLINE(AA,CLOSE,OPEN,2.6,0),COLOR0000AA;
STICKLINE(AA,CLOSE,OPEN,2.2,0),COLOR0000CC;
STICKLINE(AA,CLOSE,OPEN,1.8,0),COLOR0000DD;
STICKLINE(AA,CLOSE,OPEN,1.3,0),COLOR0000FF;
STICKLINE(AA,CLOSE,OPEN,0.5,0),COLORCC66FF;
STICKLINE(BB,CLOSE,OPEN,3.2,0),COLOR777700;
STICKLINE(BB,CLOSE,OPEN,2.6,0),COLORAAAA00;
STICKLINE(BB,CLOSE,OPEN,2.2,0),COLORBBBB00;
STICKLINE(BB,CLOSE,OPEN,1.8,0),COLORDDDD00;
STICKLINE(BB,CLOSE,OPEN,1.3,0),COLOREEFF00;
STICKLINE(BB,CLOSE,OPEN,0.5,0),COLORCYAN;
QSX:KF,COLOR00FFFF,LINETHICK3;
IF(C>QSX AND QSX>=REF(QSX,1),QSX ,DRAWNULL),LINETHICK3,COLORRED;
TYP:=(HIGH+LOW+CLOSE)/3;
CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));
CCIA:=EMA(EMA(EMA(CCI,2),2),2);
CCIB:=EMA(EMA(EMA(CCI,3),2),2);
X:=(CROSS(CCIA,CCIB) OR (CCIA>=CCIB))
AND CCIA>=-101 AND CCIA>=REF(CCIA,1)
AND REF(CCIA,1)<-101 ;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
K1:= EMA(EMA(EMA(K,2),2),2);
D1:= EMA(EMA(EMA(D,2),2),2);
J1:= EMA(EMA(EMA(J,2),2),2);
Y:= J1>REF(J1,1) ;
YJ:=X AND Y ;
DRAWICON(YJ,(LOW * 0.98),13);
DRAWTEXT(YJ,(LOW * 0.97),'买'),COLORYELLOW;

通达信红就牛主图指标公式

 

相关文章