在线检测未来函数

通达信大盘主力能量指标公式

来源:Internet,编辑:股旁网,2013-05-05

N3:=13;
M:=100;
买:=IF(O=C AND (C-REF(C,1))/REF(C,1)*100>9.8,AMOUNT,AMOUNT/((H-L)*2-ABS(O-C))*(C-L));
卖:=AMOUNT-买;
买%:=买/AMOUNT*100,COLORRED,NODRAW;
流入亿元:=AMOUNT*买%/10000000000,COLORMAGENTA,NODRAW;
流出亿元:=AMOUNT/100000000-流入亿元,COLORGREEN,NODRAW;
净流亿元:=流入亿元-流出亿元,COLORCYAN,NODRAW;
五日净流:=SUM(流入亿元-流出亿元,5),COLORCYAN,NODRAW;
十日净流:=SUM(流入亿元-流出亿元,10),COLORCYAN,NODRAW;
VA0:=IF(CLOSE>=REF(C,1),买,-卖*M/100);
A:=MA(买,3)COLORYELLOW;
B:=MA(买,5)COLORMAGENTA;
ZF0:=(C-REF(C,1))/REF(C,1);
ZL:=SUM(IF(CLOSE=REF(CLOSE,1),0,ABS(ZF0)*VA0),0)/1000000,COLORRED;
MA1OBV:=MA(ZL,8);
MA2OBV:=MA(ZL,13);
市场能量:MA(ZL,N3),COLORBLUE;
做多能量:IF(MA(ZL,N3)>=REF(MA(ZL,N3),1),MA(ZL,N3),DRAWNULL),COLORRED,LINETHICK2;
持股:IF(ZL>市场能量,ZL,DRAWNULL),COLORRED;
ZL,COLORRED;
做空能量:IF(MA(ZL,N3)<REF(MA(ZL,N3),1),MA(ZL,N3),DRAWNULL),COLORGREEN,LINETHICK2;
持币:IF(ZL<市场能量,ZL,DRAWNULL),COLORGREEN;
新高0:=ZL>REF(HHV(ZL,100),1);
IF(新高0=1,ZL,DRAWNULL),CIRCLEDOT,COLORMAGENTA;
新高:IF(新高0=1 AND REF(新高0,1)=0 ,ZL,DRAWNULL),COLORFF0080;
STICKLINE(新高=ZL AND COUNT(新高=ZL,20)=1,MIN(市场能量,ZL),MAX(市场能量,ZL),2,0),COLORMAGENTA;
DRAWTEXT(新高=ZL AND COUNT(新高=ZL,20)=1,(ZL+市场能量)/1.92,'持股能量新高'),COLORYELLOW;
做多新高:=做多能量>REF(HHV(做多能量,100),1);
IF(做多新高=1,做多能量,DRAWNULL),CROSSDOT,COLORMAGENTA;

通达信大盘主力能量指标公式

 

相关文章