在线检测未来函数

通达信云制MACD顶底背离指标公式

来源:Internet,编辑:股旁网,2013-05-05

VAR1:=BARSLAST(REF(CROSS(EMA(C,13) - EMA(C,34),EMA(EMA(C,13) - EMA(C,34) ,12)),1));
VAR2:=BARSLAST(REF(CROSS(EMA(EMA(C,13) - EMA(C,34) ,12),EMA(C,13) - EMA(C,34) ),1));
VAR3:=LLV(L,VAR2 + 3);
VAR4:=HHV(H,VAR1 +3);
DIFF:EMA(C,13) - EMA(C,34) ;
DEA:EMA(EMA(C,13) - EMA(C,34),12) ;
MACD:1.5 * (EMA(C,13) - EMA(C,34) - EMA(EMA(C,13) - EMA(C,34) ,12) ),NODRAW ;
STICKLINE((MACD > 0),0,MACD,2.5,0),COLOR0000CC;
STICKLINE((MACD > 0),0,MACD*0.9,2.5 ,0),COLOR0000EE;
STICKLINE((MACD > 0),0,MACD*0.8,2.5 ,0),COLOR0011FF;
STICKLINE((MACD > 0),0,MACD*0.7,2.5 ,0),COLOR0033FF;
STICKLINE((MACD > 0),0,MACD*0.6,2.5 ,0),COLOR0055FF;
STICKLINE((MACD > 0),0,MACD*0.5,2.5 ,0),COLOR0077FF;
STICKLINE((MACD > 0),0,MACD*0.4,2.5 ,0),COLOR0099FF;
STICKLINE((MACD > 0),0,MACD*0.3,2.5 ,0),COLOR00BBFF;
STICKLINE((MACD > 0),0,MACD*0.2,2.5 ,0),COLOR00DDFF;
STICKLINE((MACD > 0),0,MACD*0.1,2.5 ,0),COLOR00FFFF;
STICKLINE((MACD < 0),0,MACD,2.5 ,0),COLORCC0033;
STICKLINE((MACD < 0),0,MACD*0.9,2.5 ,0),COLOREE0033;
STICKLINE((MACD < 0),0,MACD*0.8,2.5 ,0),COLORFF1133;
STICKLINE((MACD < 0),0,MACD*0.7,2.5 ,0),COLORFF3333;
STICKLINE((MACD < 0),0,MACD*0.6,2.5 ,0),COLORFF5533;
STICKLINE((MACD < 0),0,MACD*0.5,2.5 ,0),COLORFF7733;
STICKLINE((MACD < 0),0,MACD*0.4,2.5 ,0),COLORFF9933;
STICKLINE((MACD < 0),0,MACD*0.3,2.5 ,0),COLORFFBB33;
STICKLINE((MACD < 0),0,MACD*0.2,2.5 ,0),COLORFFDD33;
STICKLINE((MACD < 0),0,MACD*0.1,2.5 ,0),COLORFFFF33;
IF(EMA(C,13) - EMA(C,34) >= EMA(EMA(C,13) - EMA(C,34) ,12),EMA(C,13) - EMA(C,34) ,DRAWNULL),COLORRED;
IF((EMA(C,13) - EMA(C,34) - EMA(EMA(C,13) - EMA(C,34) ,12) ) * 1000/EMA(C,15) > 0 AND (EMA(C,13) - EMA(C,34) - EMA(EMA(C,13) - EMA(C,34) ,12) ) * 1000/EMA(C,15) < 1.85,EMA(C,13) - EMA(C,34),DRAWNULL),COLORGREEN;
IF(EMA(C,13) - EMA(C,34) < EMA(EMA(C,13) - EMA(C,34) ,12) OR EMA(C,13) - EMA(C,34) > EMA(EMA(C,13) - EMA(C,34) ,12) AND REF(EMA(C,13) - EMA(C,34) ,1) < REF(EMA(EMA(C,13) - EMA(C,34) ,12) ,1),EMA(C,13) - EMA(C,34) ,DRAWNULL),COLORFF0000;
MACD底背离:REF(VAR3,VAR1 + 1) > VAR3 AND REF(EMA(C,13) - EMA(C,34) ,VAR1 + 1) < EMA(C,13) - EMA(C,34) AND CROSS(EMA(C,13) - EMA(C,34),EMA(EMA(C,13) - EMA(C,34) ,12) ),NODRAW,COLORRED;
DRAWTEXT(REF(VAR3,VAR1 + 1) > VAR3 AND REF(EMA(C,13) - EMA(C,34) ,VAR1 + 1) < EMA(C,13) - EMA(C,34) AND CROSS(EMA(C,13) - EMA(C,34) ,EMA(EMA(C,13) - EMA(C,34) ,12) ),EMA(EMA(C,13) - EMA(C,34) ,12)-0.04,'底'),COLOR00FFFF;
DRAWTEXT(REF(VAR3,VAR1 + 1) > VAR3 AND REF(EMA(C,13) - EMA(C,34) ,VAR1 + 1) < EMA(C,13) - EMA(C,34) AND CROSS(EMA(C,13) - EMA(C,34) ,EMA(EMA(C,13) - EMA(C,34) ,12) ),EMA(EMA(C,13) - EMA(C,34) ,12)-0.08,'背'),COLOR00FFFF;
MACD顶背离:REF(VAR4,VAR2 + 1) < VAR4 AND REF(EMA(C,13) - EMA(C,34) ,VAR2 + 1) > EMA(C,13) - EMA(C,34) AND CROSS(EMA(EMA(C,13) - EMA(C,34) ,12) ,EMA(C,13) - EMA(C,34) ),NODRAW,COLORGREEN;
DRAWTEXT(REF(VAR4,VAR2 + 1) < VAR4 AND REF(EMA(C,13) - EMA(C,34) ,VAR2 + 1) > EMA(C,13) - EMA(C,34) AND CROSS(EMA(EMA(C,13) - EMA(C,34) ,12) ,EMA(C,13) - EMA(C,34) ),EMA(EMA(C,13) - EMA(C,34) ,12)+0.08,'顶'),COLORFFFF00;
DRAWTEXT(REF(VAR4,VAR2 + 1) < VAR4 AND REF(EMA(C,13) - EMA(C,34) ,VAR2 + 1) > EMA(C,13) - EMA(C,34) AND CROSS(EMA(EMA(C,13) - EMA(C,34) ,12) ,EMA(C,13) - EMA(C,34) ),EMA(EMA(C,13) - EMA(C,34) ,12)+0.04,'背'),COLORFFFF00;
DRAWICON(CROSS(EMA(C,13) - EMA(C,34) >= EMA(EMA(C,13) - EMA(C,34) ,12),0.5),EMA(EMA(C,13) - EMA(C,34) ,12) ,5);
DRAWICON(CROSS(EMA(EMA(C,13) - EMA(C,34) ,12) >=EMA(C,13) - EMA(C,34) ,0.5),EMA(EMA(C,13) - EMA(C,34) ,12) ,6);

通达信云制MACD顶底背离指标公式

 

相关文章