在线检测未来函数

通达信肖氏顶底指标公式

来源:Internet,编辑:股旁网,2013-05-06

QW1:=(HIGH+LOW+CLOSE*2)/4;
QW3:=EMA(QW1,10);
QW4:=STD(QW1,10);
QW5:=(QW1-QW3)*100/QW4;
QW6:=EMA(QW5,5);
RK7:=EMA(QW6,10);
涨:=EMA(QW6,10)+100/2-5,LINETHICK1,COLORRED;
跌:=EMA(涨,4),LINETHICK1,COLORFFFF34;
多线:=IF(CROSS(涨,跌) AND 跌<-10,30,0),LINETHICK1,COLORFF00FF;
空线:=IF(CROSS(跌,80),70,100),COLOR0099FF,LINETHICK1;
STICKLINE(涨<REF(涨,1),涨,MA(涨,3),2,0 ),COLOR00EE00;
STICKLINE(涨<REF(涨,1),涨,MA(涨,3),1,0 ),COLOR00FF00;
STICKLINE(涨> REF(涨,1),涨,EMA(涨,3),3,0) ,COLOR0099FF;
STICKLINE(涨> REF(涨,1),涨,EMA(涨,3),2,0) ,COLOR00AAFF;
STICKLINE(涨> REF(涨,1),涨,EMA(涨,3),1,0) ,COLOR00BBFF;
DRAWICON(多线,30,1),COLORFF00FF;
DRAWTEXT(多线>0,-60,'买'),COLOR0000FF;
VAR2:=MA(CLOSE,194);
VAR3:=VAR2+2*STD(CLOSE,170);
顶:=(CLOSE>VAR3)*13*10,COLORBLUE,LINETHICK2;
VAR18:=HHV(HIGH,30);
VAR19:=LLV(LOW,30);
NL:=EMA((CLOSE-VAR19)/(VAR18-VAR19)*100,5)/8*10;
DRAWTEXT(CROSS(5,NL),-70,'底'),COLORWHITE;
VAR44:=REF(CLOSE,1);
VAR45:=SMA(MAX(CLOSE-VAR44,0),6,1)/SMA(ABS(CLOSE-VAR44),6,1)*100;
STICKLINE(CROSS(98,VAR45),0,VAR2*10+2,3,1),COLORGREEN;
DRAWTEXT(CROSS(82,VAR45),120,'卖'),COLORGREEN;

通达信肖氏顶底指标公式

 

相关文章