在线检测未来函数

通达信白银变金子主图指标公式

来源:Internet,编辑:股旁网,2013-05-13

{MACD}
N:=18;S:=26;P5:=12;M5:=9;
A:=EMA(CLOSE,S);
T:=EMA(CLOSE,P5);
B:=EMA(A,M5);
T1:=EMA(T,M5);
DEA:=EMA(T-(T1-T),2),COLORYELLOW,LINETHICK2;
DIFF:=DEA-EMA(((A-B)-(T-T1)),1)*6,COLORRED,LINETHICK2;
DRAWBAND(DIFF,RGB(130,85,100),DEA,RGB(10,115,100));
SHORT:=12;LONG:=26;MID:=9;M:=3;M1:=3;M2:=3;KG:=1;
DFC:=C-REF(C,1);
WJXS:=(LONG-SHORT)/2;
JGL_JF:=WJXS*EMA(DFC,SHORT);
DIF_JIP:=EMA(JGL_JF,LONG),COLOR1188FF,LINETHICK2;
DEA_GEM:=EMA(DIF_JIP,MID),COLORGREEN,LINETHICK2;
K_DF_J:=SMA(JGL_JF,M1,1),COLORFEDCBA;
D_DF_G:=SMA(K_DF_J,M2,1),COLOR13F8F9;
J_DF_L:=2.5*K_DF_J-1.5*D_DF_G,COLORF813F9;
RF:=REF(J_DF_L,1)COLORRED;
DF_J:=SMA(JGL_JF,M1,1),COLORFEDCBA;
DF_G:=SMA(K_DF_J,M2,1),COLOR13F8F9;
DF_L:=2.5*DF_J-1.5*DF_G,COLORF813F9;
RF1:REF(DIFF,1)COLORCYAN;
DRAWKLINE(H,O,L,C);
STICKLINE(J_DF_L>RF,O,C,2.8,0),COLOR1388D3;
STICKLINE(J_DF_L<RF,O,C,2.8,0),COLOR338833;
STICKLINE(C>RF1 AND C>DEA,CLOSE,OPEN,3,0),,COLOR000099;
STICKLINE(C>RF1 AND C>DEA,CLOSE,OPEN,2.2,0),COLOR0000CC;{红K线持股}
STICKLINE(C>RF1 AND C>DEA,CLOSE,OPEN,0.15,0),COLORCC66FF;
{蓝}
STICKLINE(C<DEA,CLOSE,OPEN,3,0),COLORFF7700;
STICKLINE(C<DEA,CLOSE,OPEN,2.2,0),COLORFF9900;
STICKLINE(C<DEA,CLOSE,OPEN,0.15,0),COLORCYAN;
DRAWTEXT_FIX(1,0.79,0.97,0,'整理或变盘 '),COLOR338833;
DRAWTEXT_FIX(1,0.79,0.93,0,'小涨或可持'),COLORLIRED;
DRAWTEXT_FIX(1,0.75,0.97,0,'青 下 跌'),COLORCYAN;
DRAWTEXT_FIX(1,0.75,0.93,0,'红 上 涨'),COLORRED;
EMA(T-(T1-T),2),COLORYELLOW,LINETHICK2;
DEA-EMA(((A-B)-(T-T1)),1)*6,COLORRED,LINETHICK1;
IF(DIFF<REF(DIFF,1),DIFF,DRAWNULL),COLORCYAN;
C33:=REF(C,1);
涨停:=IF((C-C33)*100/C33>=(10-0.01*100/C33),18,0);
STICKLINE(涨停,OPEN,CLOSE,0.001,0),COLORYELLOW;
REF(DIFF,1)COLORCYAN;

通达信白银变金子主图指标公式

 

相关文章