在线检测未来函数

通达信冠军1号上证指数指标公式

来源:Internet,编辑:股旁网,2013-05-15

SJ:=WMA(((2*INDEXC+INDEXH+INDEXL)/4-LLV(INDEXL,5))/(HHV(INDEXH,5)-LLV(INDEXL,5))*100,2);
ZJ:=WMA(0.618*REF(SJ,1)+0.382*SJ,2);
买1:=CROSS(SJ,ZJ) AND SJ<30;
卖1:=CROSS(ZJ,SJ) AND SJ>70;
VAR1:=4*SMA((INDEXC-LLV(INDEXL,5))/(HHV(INDEXH,5)-LLV(INDEXL,5))*100,5,1)-3*SMA(SMA((INDEXC-LLV(INDEXL,5))/(HHV(INDEXH,5)-LLV(INDEXL,5))*100,5,1),3.2,1);
LC:=REF(INDEXC,1);
RSI:=((SMA(MAX((INDEXC-LC),0),3,1) / SMA(ABS((INDEXC-LC)),3,1)) * 100);
买2:=CROSS(VAR1,8);
卖2:=CROSS(88,RSI);
RSV6:=(INDEXC-LLV(INDEXL,6))/(HHV(INDEXH,6)-LLV(INDEXL,6))*100;
K6:=SMA(RSV6,3,1);
D6:=SMA(K6,3,1);
J6:=3*K6-2*D6;
KDJ6买点:=CROSS(J6,D6);
J6买点:=CROSS(J6,0);
J6卖点:=CROSS(100,J6);
RSV9:=(INDEXC-LLV(INDEXL,9))/(HHV(INDEXH,9)-LLV(INDEXL,9))*100;
K9:=SMA(RSV9,3,1);
D9:=SMA(K9,3,1);
J9:=3*K9-2*D9;
J9买点:=CROSS(J9,0);
J9卖点:=CROSS(100,J9);
WRSV:=(INDEXC-LLV(INDEXL,9))/(HHV(INDEXH,9)-LLV(INDEXL,9))*100;
WK:=SMA(WRSV,3,1);
D:=SMA(WK,3,1);
KD买点:=CROSS(WK,D)&&WK<20;
KD卖点:=CROSS(D,WK)&&WK>80;
MID:=MA(INDEXC,20);
UPPER:=MID+2*STD(INDEXC,20);
LOWER:=MID-2*STD(INDEXC,20);
布林买点:=CROSS(INDEXC,LOWER);
布林卖点:=CROSS(INDEXC,UPPER);
LCC:=REF(INDEXC,1);
WRSI:=SMA(MAX(INDEXC-LCC,0),6,1)/SMA(ABS(INDEXC-LCC),6,1)*100;
相对强弱买点:=CROSS(WRSI,20);
相对强弱卖点:=CROSS(80,WRSI);
大盘G0:=(XMA(XMA(INDEXH,30),30)-XMA(XMA(INDEXL,30),30))+XMA(XMA(INDEXH,30),30);
大盘D0:=XMA(XMA(INDEXL,30),30)-(XMA(XMA(INDEXH,30),30)-XMA(XMA(INDEXL,30),30));
大盘G01:=(XMA(XMA(INDEXH,30),30)-XMA(XMA(INDEXL,30),30))*0.5+XMA(XMA(INDEXH,30),30);
大盘D01:=XMA(XMA(INDEXL,30),30)-(XMA(XMA(INDEXH,30),30)-XMA(XMA(INDEXL,30),30))*0.5;
大盘GO0:=(XMA(XMA(INDEXH,60),60)-XMA(XMA(INDEXL,60),60))*3+XMA(XMA(INDEXH,60),60);
大盘DO0:=XMA(XMA(INDEXL,60),60)-(XMA(XMA(INDEXH,60),60)-XMA(XMA(INDEXL,60),60))*3;
DRAWKLINE(INDEXH,INDEXO,INDEXL,INDEXC);
STICKLINE(CURRBARSCOUNT=1,大盘G0,大盘G0,100,5),COLORYELLOW;
STICKLINE(CURRBARSCOUNT=1,大盘D0,大盘D0,100,5),COLORYELLOW;
STICKLINE(CURRBARSCOUNT=1,大盘GO0,大盘GO0,100,5),COLORMAGENTA;
STICKLINE(CURRBARSCOUNT=1,大盘DO0,大盘DO0,100,5),COLORMAGENTA;
DRAWTEXT(ISLASTBAR,大盘G0,'卖'),COLORYELLOW;
DRAWTEXT(ISLASTBAR,大盘D0,'买'),COLORYELLOW;
DRAWTEXT(ISLASTBAR,大盘GO0,'顶'),COLORMAGENTA;
DRAWTEXT(ISLASTBAR,大盘DO0,'底'),COLORMAGENTA;
买点:=布林买点=1 OR 相对强弱买点=1 OR J6买点=1 OR J9买点=1;
卖点:=相对强弱卖点=1 OR J6卖点=1 OR J9卖点=1 OR 布林卖点=1 OR KD卖点=1 OR 卖2=1 OR 卖1=1 OR 相对强弱卖点=1;
DRAWICON(卖点=1,INDEXH,2);
DRAWICON(买点=1,INDEXL,1);
DRAWBMP(买点=1 AND INDEXL<大盘D01,INDEXL*0.995,'BUY1');
DRAWBMP(卖点=1 AND INDEXH>大盘G01,INDEXH*1.03,'SELL1');
大盘YM:EMA(SLOPE((INDEXC+INDEXH+INDEXL)/3,24)*20+(INDEXC+INDEXH+INDEXL)/3,48),POINTDOT,COLORYELLOW;
大盘YM1:EMA(大盘YM,20),COLORGREEN,LINETHICK1;
大盘YM2:EMA(大盘YM1,10),COLORGREEN,LINETHICK1;
大盘YM3:EMA(大盘YM2,10),COLORGREEN,LINETHICK1;
IF(大盘YM>=大盘YM1,大盘YM1,DRAWNULL),LINETHICK1,COLORRED;
IF(大盘YM>=大盘YM1,大盘YM2,DRAWNULL),LINETHICK1,COLORRED;
IF(大盘YM>=大盘YM1,大盘YM3,DRAWNULL),LINETHICK1,COLORRED;
IF(大盘YM<=大盘YM1,大盘YM1,DRAWNULL),LINETHICK1,COLORGREEN;
IF(大盘YM<=大盘YM1,大盘YM2,DRAWNULL),LINETHICK1,COLORGREEN;
IF(大盘YM<=大盘YM1,大盘YM3,DRAWNULL),LINETHICK1,COLORGREEN;

通达信冠军1号上证指数指标公式

 

相关文章