在线检测未来函数

大智慧OBV画线指标公式

来源:Internet,编辑:股旁网,2013-05-16

input:n(2);
OBV:SUM(IF(CLOSE>REF(CLOSE,1),VOL,IF(CLOSE<REF(CLOSE,1),-VOL,0)),0)/1000000;
ty:=OBV;
A1:=REF(ty,N)=HHV(ty,2*N+1); B1:=FILTER(A1,N); C1:=BACKSET(B1,N+1); D1:=FILTER(C1,N);
A2:=REF(ty,N)=LLV(ty,2*N+1); B2:=FILTER(A2,N); C2:=BACKSET(B2,N+1); D2:=FILTER(C2,N);
H1:=(D1 AND NOT(D2)) OR BARSTATUS=2 OR BARSCOUNT(C)=1;
X1:=REF(BARSLAST(H1),1)+1;
L1:=(D2 AND NOT(D1));
H2:=D1 AND NOT(D2);
F1:=BACKSET(H1 AND COUNT(L1,X1)>0,LLVBARS(IF(L1,L,10000),X1));
G1:=F1>REF(F1,1); I1:=BACKSET(G1,2);
LD:=I1>REF(I1,1);
L2:=LD OR BARSTATUS=2 OR BARSCOUNT(C)=1;
X2:=REF(BARSLAST(L2),1)+1; F2:=BACKSET(L2 AND COUNT(H2,X2)>0,HHVBARS(IF(H2,H,0),X2));
G2:=F2>REF(F2,1); I2:=BACKSET(G2,2);
HD:=I2>REF(I2,1);
R1:=BACKSET(BARSTATUS=2,BARSLAST(HD)+1); S1:=R1>REF(R1,1);
T1:=BACKSET(BARSTATUS=2,BARSLAST(LD)+1); U1:=T1>REF(T1,1);
R2:=BACKSET(S1,REF(BARSLAST(HD),1)+2); S2:=R2>REF(R2,1);
T2:=BACKSET(U1,REF(BARSLAST(LD),1)+2); U2:=T2>REF(T2,1);
压一:DRAWLINE(S2,ty,S1,ty,1),COLORGreen,LINETHICK2;
撑一:DRAWLINE(U2,ty,U1,ty,1),COLORGreen,LINETHICK2;
partline(OBV,OBV>=ref(OBV,1),rgb(255,151,255),OBV<ref(OBV,1),rgb(0,255,255)),linethick2,LAYER0;
QS:=HHV(OBV,13);
RS:=llV(OBV,13);
Var1:=BACKSET(REF(QS,2)=HHV(QS,5),3);
Var2:=CROSS(Var1,0.9);
Var3:=BACKSET(REF(RS,2)=LLV(RS,5),3);
Var4:=CROSS(Var3,0.9);
压力:REF(QS,BARSLAST(Var2)),POINTDOT,ColorEA91B5;
STICKLINE(OBV,REF(QS,BARSLAST(Var2)),REF(QS,BARSLAST(Var2)),5,0),ColorEA91B5;
支撑:REF(RS,BARSLAST(Var4)),POINTDOT,Color0087FF;
STICKLINE(OBV,REF(RS,BARSLAST(Var4)),REF(RS,BARSLAST(Var4)),5,0),Color0087FF;

大智慧OBV画线指标公式

 

相关文章