在线检测未来函数

飞狐金品顶底指标公式

来源:Internet,编辑:股旁网,2013-05-19

箱顶: HHV(MA((LOW+HIGH+CLOSE+OPEN)/4,5),58),LINETHICK0,COLOR00AAFF;
箱底: LLV(MA((LOW+HIGH+CLOSE+OPEN)/4,6),88),LINETHICK0,COLOR008000;
VAR2:= EMA((HIGH+LOW+CLOSE)/3*(HHV(HIGH,10)-CLOSE)/(HHV(HIGH,10)-LLV(LOW,10))*20/10+箱底,2);
VAR3:= (3*VAR2-2*SMA(VAR2,5,1))*0.3;
VAR4:= (HHV(INDEXH,13)-INDEXC)/(HHV(INDEXH,13)-LLV(INDEXL,13));
VAR5:= EMA(3*VAR4-2*SMA(VAR4,18,1),5);
VAR6:= (INDEXC-LLV(INDEXL,8))/(HHV(INDEXH,8)-LLV(INDEXL,8));
VAR7:= 3*SMA(VAR6,3,1)-2*SMA(SMA(VAR6,3,1),5,1);
VAR8:= (INDEXC*2+INDEXH+INDEXL)/4;
VAR9:= EMA(VAR8,13)-EMA(VAR8,34);
VARA:= EMA(VAR9,5);
资金流向:= (VAR9-VARA+箱底)*1;
VARG1:= 1.86*EMA(CLOSE,5)-EMA(CLOSE,13);
趋势力度: VARG1,LINETHICK0,COLORFFAA99;
AS:= 箱底;
STICKLINE(趋势力度>=AS,AS,趋势力度,4,0),LINETHICK0,COLOR0000FF;
STICKLINE(趋势力度<=REF(趋势力度,1) AND 趋势力度>AS,AS,趋势力度,4,1),COLORFFFFFF;
STICKLINE(REF(趋势力度,2)<REF(趋势力度,1) AND 趋势力度<=REF(趋势力度,1) AND 趋势力度>AS,AS,趋势力度,4,0),LINETHICK0,COLOR008000;
STICKLINE(趋势力度<AS-0.5,AS-0.5,趋势力度,8,1),LINETHICK0,COLOR008000;
MA3: MA(CLOSE,3),LINETHICK0,COLORAAEE00;
MA21: MA(CLOSE,21),LINETHICK0,COLORFFFFFF;
DRAWTEXT(CROSS(MA3,箱底),LOW,'试'),COLOR0000FF;
DRAWTEXT(CROSS(MA3,MA21),LOW,'买'),COLOR00FFFF;
DRAWTEXT(CROSS(MA3,箱顶) AND CLOSE>箱顶,箱顶,'追'),COLOR00EEAA;
DRAWTEXT(CROSS(箱顶,MA3) AND CLOSE<箱顶,HIGH,'卖'),COLORFFAA99;
DRAWTEXT(REF(资金流向,2)<REF(资金流向,1) AND REF(资金流向,1)>资金流向 AND 资金流向>箱顶 AND CLOSE>箱顶,HIGH*1.0051,'顶'),COLORFFFFFF;
DRAWTEXT(CROSS(趋势力度,箱底),箱底,'加仓'),COLOR0000FF;

飞狐金品顶底指标公式

 

相关文章