在线检测未来函数

通达信涨停统计与分类主图指标公式

来源:Internet,编辑:股旁网,2013-05-17

涨停:=CLOSE/REF(CLOSE,1)>=1.095;
ZTCS:=COUNT(涨停,BARSLAST(涨停+1));
ZTCS90:=COUNT(涨停,90);
DRAWNUMBER(涨停,HIGH*1.04,ZTCS90),COLORYELLOW;
GZT1:=STRCAT(' 共涨停: ',CON2STR(ZTCS,0));
GZT2:=STRCAT(GZT1,'次');
SSTS1:=STRCAT(' 上市: ',CON2STR(FINANCE(42),0));
SSTS2:=STRCAT(SSTS1,'天');
NTZZT1:=STRCAT(' 距今:',CON2STR(CONST(BARSLAST(涨停)),0));
NTZZT2:=STRCAT(NTZZT1,'天有涨停');
ZTTJ1:=STRCAT(SSTS2,GZT2);
ZTTJ2:=STRCAT(ZTTJ1,NTZZT2);
ZTTJ:=STRCAT('涨停统计:',ZTTJ2);
DRAWTEXT_FIX(CURRBARSCOUNT=1,0,0,0,ZTTJ),COLORYELLOW;
{涨停分类}
个线:=EMA(EMA(CLOSE,30),9);
大线:=EMA(EMA(INDEXC,45),9);
个股1:=CLOSE/个线*100;
大盘1:=INDEXC/大线*100;
GGQD:=(个股1-大盘1);
N1:=REF(BARSLAST((C-REF(C,1))/REF(C,1)*100>9.6 AND C=H),1)+1;
回光返照:=COUNT(CROSS(MA(C,15),MA(C,5)),N1)=0 AND HHV(GGQD,20)>23 AND MA(C,5)>MA(C,30) AND GGQD<HHV(GGQD,30) AND GGQD>5 AND (C-REF(C,1))/REF(C,1)*100>9.6 AND C=H,;
ZT:=(C-REF(C,1))/REF(C,1)*100>9.5,COLORWHITE;
开盘:=IF(REF(ZT,1)>0 ,(O-REF(C,1))/REF(C,1)*100,0),NODRAW;
BIAS1 :=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
BIAS2 :=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
BIA:=(BIAS1-BIAS2);
BIS:=LLV(BIAS1,3);
超跌涨停:=ZT>0 AND BIS<0 AND BIA>5 AND MA(C,5)<MA(C,60);
DRAWTEXT(超跌涨停,L*0.98,'超跌涨停'),COLORGREEN;
MA5:=MA(C,5);
MA10:=MA(C,10);
MA20:=MA(C,20) ;
MA30:=MA(C,30);
MA60:=MA(C,34);
F1:=(MA5-MA10)/MA10*100;
F2:=(MA10-MA20)/MA10*100;
F3:=(MA20-MA60)/MA10*100;
拉升涨停:=F1>1 AND F2>3 AND F3>0 AND ZT>0;
A1:=REF(C,20)=HHV(C,2*20+1);B1:=FILTER(A1,20);C1:=BACKSET(B1,20+1);HD:=FILTER(C1,20);
A:=REF(H,BARSLAST(HD));
RSI1:=SMA(MAX(CLOSE-REF(CLOSE,1),0),5,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),5,1)*100;
钝化涨停:=ZT>0 AND RSI1=HHV(RSI1,5) AND RSI1>80;
钝化涨停1:=GGQD>15 AND ZT>0 AND RSI1=HHV(RSI1,5) AND RSI1>80 AND REF(GGQD>15 AND ZT>0 AND RSI1=HHV(RSI1,5) AND RSI1>80,1)=0;
新股首次:=COUNT(ZT>0,BARSCOUNT(C))=1 AND ZT>0 AND FINANCE(42)<100;
突破涨停:=CROSS(C,A) AND ZT>0;
DRAWTEXT(回光返照,L*0.94,'回光返照'),COLORBLUE;
DRAWTEXT(拉升涨停,L*0.99,'拉升涨停'),COLORRED;
DRAWTEXT(突破涨停,L*0.97,'突破涨停'),COLORYELLOW;
DRAWTEXT(新股首次,L*0.96,'新股首次'),COLORMAGENTA;
DRAWTEXT(钝化涨停1,L*0.98,'钝化涨停1'),COLORLIGRAY;
DRAWTEXT(钝化涨停,L*0.95,'钝化涨停'),COLORLIBLUE;
STICKLINE(CLOSE,REF(HIGH,BARSLAST(涨停)),REF(HIGH,BARSLAST(涨停)),0.1,0),COLORDDDD00;
STICKLINE(CLOSE,REF(LOW,BARSLAST(涨停)),REF(LOW,BARSLAST(涨停)),0.1,0),COLOR00DDDD;
DRAWTEXT_FIX(ISLASTBAR,0,0.999,0,'情绪冲动 未设止赢止损 短期暴涨 有疑问的企业 不要下单!'),COLOREEEEEE;

通达信涨停统计与分类主图指标公式

 

相关文章