在线检测未来函数

通达信3n1主图指标公式

来源:Internet,编辑:股旁网,2013-05-18

SHORT:=12;
LONG:=26;
MID:=9;
DIF:=EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);
DEA:=EMA(DIF,MID);
MACD:=(DIF-DEA)*2,COLORSTICK;
STICKLINE(DIF>DEA,OPEN,C,3,0),COLORRED;
STICKLINE(DIF<DEA,OPEN,C,3,0),COLOR338833;
N:=9;
M1:=3;
M2:=3;
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:=SMA(RSV,M1,1);
D:=SMA(K,M2,1);
J:=3*K-2*D;
STICKLINE(J>D,OPEN,(CLOSE+OPEN)/2,3,0),COLORRED;
STICKLINE(J<D,OPEN,(CLOSE+OPEN)/2,3,1),COLOR338833;
LC:=REF(CLOSE,1);
RS1:=SMA(MAX(CLOSE-LC,0),12,1)/SMA(ABS(CLOSE-LC),12,1)*100;
VM:=MA(RS1,6),COLORFF00FF,NODRAW;
STICKLINE(RS1>VM AND RS1>70,O,C,3,0),COLOR009393;
STICKLINE(RS1>VM AND RS1>70,O,C,2.2,0),COLOR00C6C6;
STICKLINE(RS1>VM AND RS1>70,O,C,0.5,0),COLORYELLOW;
DRAWTEXT_FIX(1,0.70,0.95,0,'使用说明: '),COLORYELLOW;
DRAWTEXT_FIX(1,0.85,0.97,0,'上绿或全绿变盘 '),COLOR338833;
DRAWTEXT_FIX(1,0.85,0.93,0,'下红上绿或可持'),COLORWHITE;
DRAWTEXT_FIX(1,0.78,0.93,0,'全红 上 涨'),COLORRED;
DRAWTEXT_FIX(1,0.78,0.97,0,'全黄 大牛'),COLORYELLOW;

通达信3n1主图指标公式

 

相关文章