在线检测未来函数

通达信藏锋KDJ指标公式

来源:Internet,编辑:股旁网,2013-05-18

周J:=MA("KDJ.J#WEEK"(9,3,3) ,5),COLORFFFF00,LINETHICK2;
AA:=IF(周J<=0 ,-10,0),COLOR00CCCC,LINETHICK3;
DRAWBAND(0,RGB(250,0,0),AA,RGB(0,0,0));
BB:=IF(周J>=85 ,110,100),COLORYELLOW,LINETHICK3;
DRAWBAND(BB,RGB(0,250,0),100,RGB(0,0,0));
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:SMA(RSV,2,1);
D:SMA(K,2,1);
J:3*K-2*D,COLORWHITE;
周K:="KDJ.K#WEEK"(9,3,3),COLORLIMAGENTA,LINETHICK2;
周D:="KDJ.D#WEEK"(9,3,3),COLORDDDD00,LINETHICK2;
金叉:IF(CROSS(周K,周D),10,0),COLORRED,LINETHICK2;
DRAWBAND(周金叉,RGB(250,0,0),0,RGB(0,0,0));
周死叉:IF(CROSS(周D,周K),90,100), COLORFFFF00,LINETHICK2;
DRAWBAND(100,RGB(0,250,250),周死叉,RGB(0,0,0));
月K:="KDJ.K#MONTH"(9,3,3),COLORGRAY;
月D:="KDJ.D#MONTH"(9,3,3),COLORLIGRAY;
月J:="KDJ.J#MONTH"(9,3,3),COLORLIGRAY;
DRAWTEXT_FIX(1,0.06,0.23,0,'周K:')COLOR0080FF;
DRAWNUMBER_FIX(1,0.14,0.23,0,CONST((周K))),COLORYELLOW;
NOTEXT7:100,COLORWHITE;NOTEXT8:90,COLORRED;NOTEXT9:80,DOTLINE,COLORYELLOW;
NOTEXT10:20,DOTLINE,COLORGREEN;NOTEXT11:10,COLORRED;NOTEXT12:0,COLORYELLOW;NOTEXT13:50,COLORRED;
NOTEXT1:IF(K<REF(K,1),K,DRAWNULL),COLORGREEN,LINETHICK1;
NOTEXT2:IF(D<REF(D,1),D,DRAWNULL),COLORGREEN,LINETHICK1;
NOTEXT3:IF(J<REF(J,1),J,DRAWNULL),COLORFFFF00,LINETHICK1;
NOTEXT4:IF(K>REF(K,1),K,DRAWNULL),COLORRED,LINETHICK1;
NOTEXT5:IF(D>REF(D,1),D,DRAWNULL),COLORRED,LINETHICK1;
NOTEXT6:IF(J>REF(J,1),J,DRAWNULL),COLORFF00FF,LINETHICK1;
DRAWTEXT_FIX(1,0.23,0.23,0,'周D:')COLOR0080FF;
DRAWNUMBER_FIX(1,0.34,0.23,0,CONST((周D))),COLORYELLOW;
DRAWTEXT_FIX(1,0.06,0.5,0,'月K:')COLOR0080FF;
DRAWNUMBER_FIX(1,0.14,0.5,0,CONST((月K))),COLORYELLOW;
DRAWTEXT_FIX(1,0.23,0.5,0,'月D:')COLOR0080FF;
DRAWNUMBER_FIX(1,0.34,0.5,0,CONST((月D))),COLORYELLOW;
DRAWTEXT_FIX(1,0.42,0.23,0,'周J:')COLOR0080FF;
DRAWNUMBER_FIX(1,0.51,0.23,0,CONST((周J))),COLORYELLOW;
DRAWTEXT_FIX(1,0.42,0.5,0,'月J:')COLOR0080FF;
DRAWNUMBER_FIX(1,0.51,0.5,0,CONST((月J))),COLORYELLOW;
DRAWTEXT(CROSS(K,D),D,'▲'),COLORYELLOW;

通达信藏锋KDJ指标公式

 

相关文章