在线检测未来函数

通达信另类资金波段指标公式

来源:Internet,编辑:股旁网,2013-05-21

仅从资金角度来看是否持股,准确率非常非常高,它和其它大多数指标完全不同,很有用,无未来函数,也没有使用未来数据.

{资金进出}
Z_X0:=SMA(AMOUNT,10,1)/10000000;
XL_1:=(Z_X0-LLV(Z_X0,4))/(HHV(Z_X0,4)-LLV(Z_X0,4))*100;
XL_2:=LLV(Z_X0,4)+SMA(XL_1,4,1)/100*(HHV(Z_X0,4)-LLV(Z_X0,4));
XL_3:=SMA(XL_2,3,1);
资金:Z_X0,,NODRAW,COLORFFA9FF;
分界:=MA(Z_X0,8);
{大盘--转向三角}
Z_X1:=REF(EMA(Z_X0,5),1);
Z_X2:=(EMA(Z_X0,5)-Z_X1)/Z_X1*100;
Z_X3:=REF(EMA(Z_X0,5),BARSLAST(CROSS(Z_X2,0))+1);
Z_X4:=REF(EMA(Z_X0,5),BARSLAST(CROSS(0,Z_X2))+1);
{大盘--资金进出}
STICKLINE(Z_X0<REF(Z_X0,1)||(AMOUNT/REF(AMOUNT,1)<0.97),Z_X0,REF(Z_X0,1),3,0),LINETHICK2,COLORWHITE;{//白线离场}
STICKLINE(Z_X0>=REF(Z_X0,1),Z_X0,REF(Z_X0,1),3,0),LINETHICK2,COLORRED;{//红线进场}
STICKLINE(Z_X0<分界,Z_X0,REF(Z_X0,1),3,0),LINETHICK2,COLORGREEN;{//绿线空仓}
{大盘--转向}
DRAWLINE(CROSS(Z_X2,0),Z_X1,CROSS(0,Z_X2),Z_X1,0),COLORFF6FFF;{//粉红--斜线}
IF(Z_X2>=0 AND Z_X3=REF(Z_X3,1),Z_X3,DRAWNULL),COLORFF6FFF; {//粉红--直线}
DRAWLINE(CROSS(0,Z_X2),Z_X1,CROSS(Z_X2,0),Z_X1,0),COLORGREEN;{//绿--斜线}
IF(Z_X2<0 AND Z_X4=REF(Z_X4,1),Z_X4,DRAWNULL),COLORGREEN; {//绿--直线}
DRAWLINE(CROSS(0,Z_X2) OR CROSS(Z_X2,0),Z_X1,ISLASTBAR,Z_X1,0),COLORYELLOW; {//黄--最后斜线向改个};

通达信另类资金波段指标公式

 

相关文章