在线检测未来函数

飞狐歪虎动平衡指标公式

来源:Internet,编辑:股旁网,2013-06-05

S下:=HHV(MA(HIGH,2),2),COLORGREEN,LINETHICK2;
S上:=LLV(MA(HIGH,2),1),COLORRED,LINETHICK2;
Sppp:-(S上-S下)/ref(c,1)*100;
Sptem1:=(min(o,c)-l)/(h-l)*100;
Sptem2:=(h-max(o,c))/(h-l)*100;
SPTEM3:=(c-o)/(h-l)*100;
SKJ1:=(SPTEM3>49 AND SPTEM1>0.3*SPTEM2) OR SPTEM3>80;
SKJ2:=(SPTEM3<=49 AND SPTEM3>20 AND SPTEM1>SPTEM2);
SKJ3:=(SPTEM3<=20 and sptem3>-20 and sptem1>1.2*sptem2);
SKJ4:=(SPTEM3<-20 AND SPTEM3>-40 AND SPTEM1>2*SPTEM2);
SKJ:=(SKJ1 OR SKJ2 OR SKJ3 OR SKJ4) AND (Sppp>2 or ref(Sppp,1)>2 );
短买:if(sum(sppp>0,5)=5 and sum(skj>0,5)=0,5*(SKJ1 OR SKJ2 OR SKJ3 OR SKJ4),5*skj),STICK,COLORRED;
x下:=HHV(MA(l,2),1),COLORGREEN,LINETHICK2;
x上:=LLV(MA(l,2),2),COLORRED,LINETHICK2;
xppp:(x上-x下)/ref(c,1)*100;
xptem1:=(min(o,c)-l)/(h-l)*100;
xptem2:=(h-max(o,c))/(h-l)*100;
XPTEM3:=(c-o)/(h-l)*100;
XKJ1:=(XPTEM3<-49 AND SPTEM2>0.3*SPTEM1) OR SPTEM3<-80;
XKJ2:=(SPTEM3>=-49 AND SPTEM3<-20 AND SPTEM1<SPTEM2);
XKJ3:=(SPTEM3>=-20 and sptem3<20 and sptem2>1.2*sptem1);
XKJ:=(XKJ1 OR XKJ2 OR XKJ3) AND (Xppp<-2 or ref(Xppp,1)<-2 );
短卖:(-5)*FILTER(xkj,0),STICK,COLORGREEN;
5;-5;

飞狐歪虎动平衡指标公式

 

相关文章