在线检测未来函数

同花顺量能三线突破主图指标公式

来源:Internet,编辑:股旁网,2013-06-12

义阳量能平台,突破、支撑、压力一目了然。 K线站在紫色平台以上突破看涨,在平台以下跌破看跌。 注意:这本身是个主图指标,安装上后可能只有平台线,没有K线,请安装上后,在指标上右键点击修改指标——曲线属性——附图指标--现则“叠加K线”。就可以显示K线了!

MA(C,3);
N:=10;
T1:=CONST(HHVBARS(V,N));
T0:IF(CURRBARSCOUNT<=N+3,CONST(IF(T1=0,C,REF(C,T1))),DRAWNULL),COLORFF00FF;
IF(CURRBARSCOUNT=T1+1,T0,DRAWNULL),CIRCLEDOT,COLORFF00FF;
DRAWTEXT(ISLASTBAR,T0,' 量能平台'),COLORCC00CC;
X:=30;
X1:=CONST(REF(HHVBARS(V,X),T1+1)+T1+1);
X0:IF(CURRBARSCOUNT<=T1+X+3 AND CURRBARSCOUNT>=T1+1,CONST(REF(C,X1)),DRAWNULL),COLOR999999;
IF(CURRBARSCOUNT=X1+1,X0,DRAWNULL),CIRCLEDOT,COLORCCCCCC;
W:=20;
W1:=CONST(REF(HHVBARS(V,W),T1+1)+T1+1);
W0:IF(CURRBARSCOUNT<=T1+W+3 AND CURRBARSCOUNT>=T1+1,CONST(REF(C,W1)),DRAWNULL),COLOR009999;
IF(CURRBARSCOUNT=W1+1,W0,DRAWNULL),CIRCLEDOT,COLOR00CCCC;
M:=10;
Q1:=CONST(REF(HHVBARS(V,M),T1+1)+T1+1);
Q0:IF(CURRBARSCOUNT<=T1+M+3 AND CURRBARSCOUNT>=T1+1,CONST(REF(C,Q1)),DRAWNULL),COLOR009900;
IF(CURRBARSCOUNT=Q1+1,Q0,DRAWNULL),CIRCLEDOT,COLOR00CC00;

同花顺量能三线突破主图指标公式

 

相关文章