在线检测未来函数

通达信农场主图指标公式

来源:Internet,编辑:股旁网,2013-06-13

MA1:MA(CLOSE,5);
MA2:MA(CLOSE,10);
MA3:MA(CLOSE,20);
MA4:MA(CLOSE,60);
{红土地=牛股}
MA5:=MA(C,78),COLOR00FFFF,LINETHICK1;
MA6:=EMA(MA5,3),COLOR00FFFF,LINETHICK1;
MA7:=EMA(MA6,3),COLOR00FFFF,LINETHICK1;
Y:=(H+L)/2;
AO:=MA(Y,5)-MA(Y,34 );
DU0:=CROSS(AO,0);
UD0:=CROSS(0,AO);
TDU0:=BARSLAST(DU0);
TUD0:=BARSLAST(UD0);
DU3:=REF(DU0,1);
UD3:=REF(UD0,1);
TDU3:=BARSLAST(DU3);
TUD3:=BARSLAST(UD3);
UDGLINE:=IF(TDU3<TUD3,REF(HHV(H,2),TDU3),REF(LLV(L,2),TUD3)),COLORYELLOW;
JDU0:=REF(C,1)<=REF(UDGLINE,1) AND C>UDGLINE AND TDU0<TUD0;
JUD0:=REF(C,1)>=REF(UDGLINE,1) AND C<UDGLINE AND TUD0<TDU0;
JDU1:=JDU0 AND COUNT(JDU0,TDU0)=1;
JUD1:=JUD0 AND COUNT(JUD0,TUD0)=1;
JDU2:=JDU1 AND REF(BARSLAST(JUD1),1)<REF(BARSLAST(JDU1),1);
DRAWTEXT(JDU2,MA7*0.95,'红土地'),COLORYELLOW;
DRAWTEXT(CROSS(MA3,MA4),MA4*0.98,'风调雨顺'),COLOR0000FF;
DRAWTEXT(CROSS(MA4,MA3),MA3*0.98,'灾情来临'),COLORFF0000;
{浇水=回马枪}
SC:=C/REF(C,1)>1.097;
HS:=MA(C,2);
浇水:=CROSS(HS,REF(HS,1)) AND REF(HHV(SC,8),1);
STICKLINE(浇水,L,O,1,0),COLORF00F00;
DRAWICON(浇水,L*0.995,9);
DRAWTEXT(浇水,L*0.98,'浇水'),COLOR0000FF;
{STICKLINE(抓牛,L,O,2,0),COLOR0000FF;
DRAWICON(抓牛,L*1.11,1),COLOR0000FF;}
HSC1:=C>O AND V>REF(V,1) AND REF(SC,1);
HSC2:=REF(HHV(V,8),1)/V>=1.97 AND REF(HHV(HSC1,8),1) AND C>O;
DRAWTEXT(HSC2,L*0.92,'施肥'),COLORFF00FF;
{自制通信达}
上线:=SMA(C,2,1);
下线:=SMA(C,6,1);
上线1:=SMA(C,2,1);
下线1:=SMA(C,6,1);
DRAWTEXT( CROSS(上线,下线),LOW *0.98,'种菜' ),COLOR00FF00;
DRAWTEXT(CROSS(下线1,上线1),H*1.02,'收获'),COLORYELLOW;
BBI:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
UPR:=BBI+3*STD(BBI,13),LINETHICK2;
DWN:=BBI-3*STD(BBI,13);
安全:=MA(CLOSE,60),LINETHICK2;
LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
DRAWTEXT( CROSS(88,RSI) , HIGH*1.02,'偷菜') ,COLORFF9966,LINETHICK2;
A7:=(2*C+H+L)/4;
操作:=MA(A7,5),LINETHICK2;
操作1:=MA(A7,5)*1.03,LINETHICK2;
操作2:=MA(A7,5)*0.97,LINETHICK2;
VAR1:=LLV(A7,21);
VAR2:=HHV(A7,21);
SK:=EMA((A7-VAR1)/(VAR2-VAR1)*100,7);
SD:=EMA(0.667*REF(SK,1)+0.333*SK,5);
DRAWTEXT(IF(COUNT(CLOSE<REF(CLOSE,1),8)/8>6/10 AND VOL>=1.5*MA(VOL,5) AND
COUNT(SK>=SD,3) AND REF(LOW,1)=LLV(LOW,120),1,0),LOW*0.98,'种瓜') ,COLOR0099FF;
DRAWTEXT(IF(COUNT(CLOSE<REF(CLOSE,1),13)/13>6/10 AND
COUNT(SK>SD,6) AND REF(LOW,5)=LLV(LOW,120) AND REF(CLOSE>=OPEN,4) AND
REF(CLOSE>OPEN,3) AND REF(CLOSE>OPEN,2) AND REF(OPEN>CLOSE,1) AND
OPEN>REF(CLOSE,1),1,0),LOW*0.98,'种瓜') ,COLORYELLOW;
D:=MA(CLOSE,80)-MA(CLOSE,10)/3;
DRAWTEXT(IF(CLOSE<D AND VOL/240>MA(VOL,5)/240 AND CLOSE>REF(CLOSE,1)*1.08
AND CLOSE<MA(CLOSE,13)*1.3,1,0),LOW*0.98,'种豆'),COLORYELLOW;

通达信农场主图指标公式

 

相关文章