在线检测未来函数

通达信五行生旺指标公式

来源:Internet,编辑:股旁网,2013-06-20

本公式是对多空布林进行了优化,原理:股价在轨道间运行,多空线向下靠近下轨,布林线收口,当股价从多空线下站上多空线为买入,多空线靠近上轨,股价跌破上轨卖出。公式不是万能的,应结合其它指标(如MACD等)使用。股

A1:MA(C,3);
A2:MA(C,8);
DRAWBAND(A1,180,A2,RGB(39,139,39));
A3:MA(C,24);
A4:MA(C,72);
A5:=MA(C,216);
胎:=A1<A2 AND A1>REF(A1,1);
养:=CROSS(A1,A2);
长生:=A1>A2 AND A1>REF(A1,1) AND A1/A2<1.01;
沐浴:=A1>A2 AND A1>REF(A1,1) AND A1/A2<1.02 AND A1/A2>1.01;
冠带:=A1>A2 AND A1>REF(A1,1) AND A1/A2<1.03 AND A1/A2>1.02;
临官:=A1>A2 AND A1>REF(A1,1) AND A1/A2<1.05 AND A1/A2>1.03;
帝旺:=A1>A2 AND A1>REF(A1,1) AND A1/A2<1.30 AND A1/A2>1.05;
衰:=A1>A2 AND A1<=REF(A1,1) AND A1/A2<1.09;
病:=A1<A2 AND A1<=REF(A1,1) AND A1/A2<1.05 AND A1/A2>1;
死:=A1<A2 AND A1<=REF(A1,1) AND A1/A2<1 AND A1/A2>0.98;
墓:=A1<A2 AND A1<=REF(A1,1) AND A1/A2<0.98 AND A1/A2>0.96;
绝:=A1<A2 AND A1<=REF(A1,1) AND A1/A2<0.96 AND A1/A2>0.85;
DRAWTEXT(胎,A1,'胎'),COLORWHITE;
DRAWTEXT(养,A1*0.99,'养'),COLORWHITE;
DRAWTEXT(长生,A1,'长生'),COLORYELLOW;
DRAWTEXT(沐浴,A1,'沐浴'),COLORYELLOW;
DRAWTEXT(冠带,A1,'冠带'),COLORYELLOW;
DRAWTEXT(临官,A1,'临官'),COLORYELLOW;
DRAWTEXT(帝旺,A1,'帝旺'),COLORYELLOW;
DRAWTEXT(衰,A1,'衰'),COLORGREEN;
DRAWTEXT(病,A1,'病'),COLORGREEN;
DRAWTEXT(死,A1,'死'),COLORGREEN;
DRAWTEXT(墓,A1,'墓'),COLORGREEN;
DRAWTEXT(绝,A1,'绝'),COLORGREEN;

通达信五行生旺指标公式

 

相关文章